2

Im a lubuntu 20.04 user, and I'm trying to change my mac adress. I'm following a tutorial on linux hint since I don't really know anything and I entered the command "ifconfig enp0s31f6 down" to turn my network card down.

example@file:~$ ifconfig enp0s31f6 down
SIOCSIFFLAGS: Operation not permitted

Can someone tell me how to fix it or what I'm doing wrong ? Thanks

1
  • since I don't really know anything ....... You rarely need to change network device MAC addresses. I suggest leaving the MAC the way it was.
    – John
    Dec 11, 2021 at 16:12

2 Answers 2

1

This requires roots privs and cannot be changed by an ordinary user.

Try sudo ifconfig enp0s31f6 down

1
  • Ok thanks it worked.
    – Jean
    Dec 11, 2021 at 16:15
0

Had same error running Metasploit in Kali. Issue was that I was logged in as the kali user and this user didn't have permissions. Once I switched to root $ sudo su and then ran Metasploit # msfconsole, I didn't get SIOCSIFFLAGS error anymore.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .