I tried

HandBrakeCLI -i file1.mkv -o output.mp4 -e nvenc_h264 --encopts="gpu=1"

where gpu=1 means my nVidia 3070. It'd stop about 2 seconds after it prints:

03:11:13 encavcodecInit: H.265 (Nvidia NVENC)
Encoding: task 1 of 1, 0.00%

I tried removing


and it didn't work. I tried changing to 0 and it didn't work. I also tried


in the docs here and it didn't work. I also tried gpu=any and it didn't work.

Can it be made to work at all? I saw an article saying it is about 5 times as fast as using the CPU to encode.

  • What is your end goal here? If it just is switching the format (container), and you don't really want to change the video, you could easily use ffmpeg instead. If you want to transcode the video to be visually lossless with a smaller file size, you should try Other Video Transcoding by Don Melton, it does a great job at that as it is made to "compress" ripped BluRays May 11, 2022 at 17:06

1 Answer 1


HandBrakeCLI -i in.mkv -o out.mkv -e nvenc_h265

tried all your steps without result.

adding -e nvenc_h265 worked for me

  • 2
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    May 11, 2022 at 16:53
  • so the only thing different is that you use -e nvenc_h265 instead of my -e nvenc_h264? I need to double check to confirm it is working May 15, 2022 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .