While trying to solve a more complicated networking problem, I noticed that for some reason I was getting no response to a ping from my Windows 10 computer. I read that it might be a problem with the firewall in Windows, so I temporarily disabled it entirely for private and public networks in Control Panel. It didn't help.

On this Windows in Wireshark on the interface I see packets like this: ping

What could be the problem?

  • On the Windows 10 PC, enable (turn on) Network Discovery in Advanced Network Sharing center.
    – John
    Dec 28, 2021 at 13:58
  • I had it enabled.
    – bLAZ
    Dec 28, 2021 at 14:14
  • The inability to ping may be part of your bigger network problems. Try resetting TCP/IP. .... Open cmd.exe with Run as Administrator (1) netsh int ip reset c:\resetlog.txt (2) ipconfig /flushdns (3) restart the computer
    – John
    Dec 28, 2021 at 14:25
  • I did this reset, but unfortunatelly it doesn't help.
    – bLAZ
    Dec 29, 2021 at 10:58

2 Answers 2


On the Windows 10 PC, Network Discovery is probably disabled. It will drop every package it receives and won't respond. To turn Network Discovery on:

  1. Open the Control Panel (for example, by searching the Start menu).
  2. Under "Network and Internet", click on "View network status and tasks".
  3. On the left sidebar, click "Change advanced sharing settings".
  4. Select "Turn on network discovery" for the desired profiles. Look for the label "current profile" for the active network connection.
  • I had it enabled all the time.
    – bLAZ
    Dec 28, 2021 at 14:12

I also had a Windows 10 PC that wouldn't respond to pings. Network discovery was on. However, after poking a bit I realized that somehow the Network had gotten switched to a public network. (This is a hardwired desktop PC that never moves or changes networks, so I'm not sure how this happened.) And of course I didn't have network discover enabled for Public networks.

My solution was to change the network back to Private, and now all is well. I feel like the steps to do this change often, but here is what I did:

  1. Click on the Network icon in the tray.
  2. Click on my currently connected network.
  3. Click Status on the left.
  4. Click Properties.
  5. Change Network Profile to Private.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .