2

My Windows 10 desktop computer loses its wifi connection during sleep, which is acceptable to me, but then upon waking, it takes too long to reconnect. Sometimes it doesn't even connect automatically, and I need to manually choose (in the wifi settings) to connect to my home network again. See ¹.

Also odd: sometimes upon waking, the wifi icon indicates that there is a network connection temporarily, but then it loses network connection temporarily a couple of seconds after waking.

I've had this computer for many years, and I think this problem has only happened within the past ~6 months.

I've even upgraded my USB wifi dongle to a new one, and the problem still happens. And yes, the drivers are up-to-date.

These old questions seemed relevant, but I haven't found the answer yet:

P.S. winver shows I have Windows 10 Version 2004 (OS Build 19041.1083). My new wifi USB dongle is EDUP AC1300M wifi driver EP-AC1686 Driver (8812BU Chipset).


UPDATE:

Even https://superuser.com/a/982020/74576 (un-ticked "Allow the computer to turn off this device to save power", in the "Power Management" tab of the wireless network adapter properties) did not fix the problem.

¹ Also, here is a screenshot of how upon waking I'm forced to click "Connect" even though "Connect automatically" had already been checked (but obviously isn't working).

wifi status screenshot


Update 2:

See Windows 10 WiFi connection after sleep I wonder if my Brave browser is somehow the problem. I nearly always have Brave windows open, so if Brave is somehow able to disconnect my wifi temporarily upon Windows waking up (which doesn't make sense to me), then it would be Brave's fault.


Update 3:

It's not Brave's fault. "Connect automatically" still doesn't work (upon waking from sleep) even when I'd fully exited Brave prior to sleep.

9
  • @Moab Thanks but, as I mentioned, the drivers are already updated.
    – Ryan
    Jan 1, 2022 at 14:56
  • This has been a known issue for years, but I'm unsure what the cause is or whether it's ever been addressed by Microsoft. The most efficient way I've found to fix it is to manually disconnect from the network via the taskbar's network icon, then immediately reconnect once it's registers as disconnected.
    – JW0914
    Jan 1, 2022 at 14:59
  • @JW0914 Thanks for your response. Those extra steps so many times per day are driving me crazy. It didn't use to be like this.
    – Ryan
    Jan 1, 2022 at 20:24
  • As a Workaround, on a desktop PC used for work I'd just go into power settings and set Sleep to "never" as well as Hibernate to "never" - or set it to sth like "after 2 hours".
    – 1NN
    Jan 2, 2022 at 20:33
  • @1NN I appreciate the flexible thinking. :-) But I'd personally prefer an actual solution.
    – Ryan
    Jan 2, 2022 at 20:39

4 Answers 4

3
+350

Method 1 : Power Options - Network connectivity in Standby

  • Run regedit
  • Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\F15576E8-98B7-4186-B944-EAFA664402D9
  • Set the value of Attributes to 2
  • Close regedit
  • Open Start > Power Options, where you should now have the option for "Network connectivity in Standby"
  • Enable both "On battery" and "Plugged in"
  • Reboot might be required.

enter image description here

Method 2 : Group Policy Editor

  • Run gpedit.msc
  • Navigate to Computer Configuration > Administrative Templates > System > Power Management > Sleep Settings
  • Enable "Allow network connectivity during connected-standby (on battery)" and "Allow network connectivity during connected-standby (plugged in)"
  • Reboot might be required.

Method 3 : Using powercfg

This is essentially the same as the previous method.

  • Run Command Prompt (CMD) as Administrator

  • For Battery On Option enter:

    powercfg /setdcvalueindex scheme_current sub_none F15576E8-98B7-4186-B944-EAFA664402D9 1
    
  • For Plugged In enter:

    powercfg /setacvalueindex scheme_current sub_none F15576E8-98B7-4186-B944-EAFA664402D9 1
    
  • Reboot might be required.

Method 4 : Reconnect on wake

This method is to be used when no other solution is found. On wake it runs a command for restarting the Windows service that is supposed to redo the connection (but doesn't).

  • Create a .bat file containing:

    net stop WlanSvc && net start WlanSvc
    
  • Run Start > Task Scheduler

  • Click on "Create a Task"

  • Enter suitable values in the "General"

  • In the "Triggers" tab, choose "New"

  • In the new panel choose "On an event" from the top drop-down menu

  • Choose "Custom" under Settings

  • Click "New Event Filter" and use the following:

    Event Level: Information
    Log Name: System
    Source: Power-Troubleshooter
    Event ID: 1

  • Click OK

  • In the Actions tab, choose the above .bat file

  • In the Conditions tab, uncheck "Start the task only if the computer is on AC power"

  • Click OK.

20
  • Thanks for this big answer! I've done the steps from Method 2, including the reboot. I noticed the "wifi disconnected" icon briefly in the system tray upon login after boot, which isn't a good sign, but I'll report back later with how it goes.
    – Ryan
    Jan 4, 2022 at 22:44
  • Yeah, within minutes, my network cut out, and I hadn't even put my Windows to sleep. Given that this has been happening with multiple USB wifi devices, it's unlikely to be the fault of the wifi device. But I wonder if it's some other intermittent hardware issue (such as the motherboard). That feels unlikely too since I've noticed no other symptoms. But this problem is so bizarre! I appreciate your thoughts.
    – Ryan
    Jan 4, 2022 at 22:51
  • I also did Method 1 just now, changing Attributes from 1 to 2. I haven't rebooted yet. So far, I see the new "tree" of Balanced > "Networking connectivity in Standby" > Setting: Enable. I.e. mine isn't split into "On battery" and "Plugged in", perhaps because it's a desktop. And currently Enable is grayed out and not editable.
    – Ryan
    Jan 4, 2022 at 23:16
  • 1
    This seems a problem of Windows. To verify that your Windows in as good a shape as possible: (1) Dism /Online /Cleanup-Image /RestoreHealth, (2) sfc /scannow, and finally (3) Repair Install. If all this doesn't help, then this is just how Windows works today, and for me only Method 4 is left (unless someone comes up with something else).
    – harrymc
    Jan 5, 2022 at 8:17
  • 1
    I appreciate it. From my ideas, Repair Install is one you haven't done yet. This isn't a reset of Windows - it's exactly the same as doing a major Windows upgrade, although it'll only "upgrade" your version to itself. Take backups appropriately.
    – harrymc
    Jan 10, 2022 at 14:15
0

It might be an issue with your wireless card, I had the same issue & bought this gadget for around 2$ and still working good. No more issues, it has better strength than the laptop one as well

enter image description here

1
  • I've tried multiple USB wireless dongles, and the problem happens with both.
    – Ryan
    Jan 3, 2022 at 14:21
0
  1. Check for malware using a trusted antivirus software.
  2. Boot in Safe Mode. If Wi-Fi works in Safe Mode it's a problem with something you installed.
  3. Update Windows.
1
  • I booted into Safe Mode with Networking, but apparently that only supports ethernet rather than the wifi driver, which was disabled.
    – Ryan
    Jan 9, 2022 at 16:33
0

Sorry if I missed this being menitioned.

  1. Open Device Manager and locate your wifi adapter.

  2. Change the view to Devices by Connection.

    enter image description here

  3. Check the Proerties dialog > Power Management tab for the adapter and all parent devices and uncheck Allow the computer to turn off this device to save power.

    enter image description here

4
  • 2 bits are interesting about this suggestion: 1) I'd already unchecked that box for this network adapter in recent days, but somehow it got enabled again (I wonder what re-checked its box.) 2) I hadn't thought about this view and unchecking for all parent devices. 🤞 We'll see over the next day or so. Thanks.
    – Ryan
    Jan 7, 2022 at 0:45
  • 1
    You're welcome. Interesting that it was re-enabled; probalby tied to Power Management and c ompliance with whatever standards exist for EnergyStar, etc. Devices by connection is a handy view when troubleshooting unknown/disabled devices. Sometimes deleting the parent device of an unknown device will cause it to be re-detected and identified. Jan 7, 2022 at 4:49
  • 1
    Also, you said sometimes the network appears to be connnected when waking up but is then lost. Unless you see evidence of actual network activity, I think you're probably seeing a view/state that was cached when going to sleep. The network is probably already disconnected on wake, it's just the Notification Area icon hasn't refreshed to reflect the currennt state. Jan 7, 2022 at 4:56
  • Unfortunately these steps have not solved the problem for me. Thanks anyway!
    – Ryan
    Jan 7, 2022 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.