I'm just starting out using linux and so I installed Ubuntu to a hard disk.
I noticed that after 30 minutes or so, the mouse pointer would simply stop moving while the keyboard was o.k.
Exact same problem with Fedora as well. (The mouse works fine in Vista (it's a MS Comfort mouse 1000))

I searched and found a suggestion that I should disable the sleep settings, so I did that but no luck.

Interestingly, there is no freezing of the mouse when I use the Ubuntu Live CD - it's only the hard-disk-installed Ubuntu that's having the problem.

Update Found some old links from 2009 that say I should remove the "mouseemu" package. How to remove that package?

Update Unfortunately, that did not help - there is no mouseemu pkg installed. I tried setting kernel boot options noapic, irqpoll etc. - no luck. This is so annoying.


If you are using ArchLinux (could be applicable for other distros too), you need to find your device ID by lsusb and then add it to the blacklist in USB autosuspend by editing:


Example of the line to add:


USB autosuspend ref: Usb Autosuspend

Don't forget to restart the laptop-mode service afterwards, for the changes to become effective, e.g. by running sudo systemctl restart laptop-mode.service resp. sudo service laptop-mode restart.

  • Unfortunately, I cannot find that or any similar configuration file on Xubuntu LTS 14.04. – Serge Stroobandt Dec 29 '14 at 12:14
  • 1
    @SergeStroobandt Try installing this package: packages.ubuntu.com/lucid/utils/laptop-mode-tools Hope it helps – jadelord Jan 9 '15 at 15:40
  • On debian I had to create this file on my own. Do I have to restart anything to let those changes become effective? – white_gecko Nov 27 '15 at 12:19
  • 1
    Ah ok, one has to restart "laptop-mode" (e.g. by running sudo systemctl restart laptop-mode.service). I just didn't find it because the keyboard was suspended during tab-completion ;-) – white_gecko Nov 27 '15 at 12:23
  • Sometimes unplug/plug usb cable also necessary. – Vlad Dec 2 '15 at 16:23

Sounds like it might be an issue with usb autosuspend.

Try adding usbcore.autosuspend=0 to your boot command to disable autosuspend completely (in Ubuntu 10.04 this works, not sure about Fedora - they may load usbcore as a module).

Alternatively, you may be able to disable autosuspend on a more fine-grained level by doing:

echo on > /sys/bus/usb/devices/usb2/power/level

^ this is the path on my machine, yours is probably slightly different. Currently this should be set to auto; setting it to on will disable autosuspend on that interface.

  • I did that change (in /boot/grub/menu.lst), and the mouse didn't freeze for about 2 hours - and then it froze again :( – Zabba Jul 30 '10 at 7:30
  • This is not working after suspend. :( – Dinuka Thilanga May 4 '20 at 13:20

to remove package mouseemu, do:

sudo apt-get remove mouseemu

I don't know if that will solve your problem.

  • Unfortunately, that did not help - there is no mouseemu pkg installed. I tried setting kernel boot options noapic, irqpoll etc. nothing works. This is so annoying! – Zabba Jul 30 '10 at 3:42
  • If the mouse really works OK when booted from the Ubuntu live CD, then it sure sounds like a bad installation. Perhaps you could try installing the OS again. – Marnix A. van Ammers Aug 1 '10 at 14:09

I had the same problem. The mouse suddenly freezes and in /var/log/messages:

USB disconnect, address XX

I had to reinstall compiz:

sudo apt-get purge compiz*
cd $HOME && rm -rf .compiz/ .config/compiz/

I had the same problem on my Fedora 15.

Mouse was constantly hang for couple milliseconds and then everything was ok again. 10-40 seconds and the same thing was happening again.

I stumbled on this link https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Touchpad_synchronization_issues in /var/log/messages-* , I found that USB mouse was constantly found and lost.

After that I plugged my mouse in different USB and now computer is super fast and no glitches experienced so far. :)

  • Yeah, even plugging the mouse in and out of the same USB socket unfreezes the mouse, but a little while later it happens again. – Serge Stroobandt Dec 29 '14 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.