I had a situation where a VM in Hyper-V on Win 10 Pro (build 19043.1415) wouldn´t stop and the first thing I did was stopping various services related to Hyper-V. After that I rebooted the host, and suddenly all my VM`s were no longer listed in Hyper-V. I thought this was weird, cause usually you´d expect these services to come back after a reboot. Anyway, I tried restarting services related to Hyper-V, but they all seemed to have a dependency, unnamed, prevending them from running. After a bit of trying to resolve it, I decided to simply uncheck Hyper-V as installed, reboot and then check it as installed + reboot again. Now I could see my machines again, but ran into a new problem: The virtual internal switch that I use for connecting through my VPN was gone. So I tried creating it, both with Hyper-V and from PowerShell, but with the same result:

New-VMSwitch -Name Intern -SwitchType Internal
New-VMSwitch : Virtuelle Ethernet-switchforbindelser kunne ikke tilføjes.
Intern miniport kunne ikke oprettes. Navn = '1F870B16-E6E9-4D9E-83EC-7A114ACB9A49', brugervenligt navn = '', MAC = 'DYN
AMIC': Not found (0x80041002).
At line:1 char:1
+ New-VMSwitch -Name Intern -SwitchType Internal
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [New-VMSwitch], VirtualizationException
    + FullyQualifiedErrorId : Unspecified,Microsoft.HyperV.PowerShell.Commands.NewVMSwitch

Please bear with the message being in Danish, but it´s basically telling that Virtual internet switch connections could not be added and the internal miniport could not be created. The same thing happened when trying to add an external switch. It takes up to 10 mins before I get the message btw. I found others with what seemed to be a similar problem, but here the solution was to remove Hyper-V (in already mentioned way) and do a netcfg -d, reboot, reinstall hyper-v and reboot, but this did not make any difference for me. I also found a quick fix from MS, that also did not improve my situation.

Some good ideas apart from reinstalling Windows?

Edit: Added list showing states of all hyper-v related services in my system.

a busy cat

Edit: Did a repair install of Win 10, but this did not solve the problem.

Edit: Did a sfc /scannow - same result.

Edit: Current output for relevant info from CoreInfo64:

    HYPERVISOR * Hypervisor is present 
    VMX - Supports Intel hardware-assisted virtualization 
    SVM - Supports AMD hardware-assisted virtualization
  • Without knowing which services you manually turned off it will be difficult to answer this question. The command to create a new virtual switch will obviously NOT work if the required service is not running. With regards to the service not starting, what can you tell us about that error, since the error you provided is completely and totally expected in your system's current state. Is the image in this article the error in question?
    – Ramhound
    Jan 6, 2022 at 20:11
  • Should the services not start again as per the settings after a reboot, and especially after reinstalling Hyper-V, that I would expect to reset them to their defaults? Anyway, the error showing in the article looks a lot like what I got when trying to load server from local computer before I restored Hyper-V. Maybe you can gather something from the screenshot from Process Hacker 2 I´ve added in the initial post, showing states of hyper-v services. It´s the same services I was fiddling with when it all went down.
    – Corey Hart
    Jan 6, 2022 at 21:27
  • Everything is in Danish. I don't read Danish
    – Ramhound
    Jan 6, 2022 at 22:33
  • Sorry about that, updated the list with English equivalents.
    – Corey Hart
    Jan 6, 2022 at 22:52
  • Does CoreInfo64 indicate your system does or doesn’t support hardware virtualization. I have a theory.
    – Ramhound
    Jan 11, 2022 at 1:57

1 Answer 1


Found the solution: Unistalled Comodo Internet Security, rebooted and I could proceed with creating the switch. I did not have to do this when I created a switch a few months ago, but there´s probably a conflict between Comodo and a recent Win 10 update causing this.

  • Just an FYI, there's little point to running a 3rd party AV with Windows Defender in Win10+ consistently scores on par with the top rated 3rd party AVs in independent testing.
    – JW0914
    Jan 12, 2022 at 16:24
  • Yeah, it´s not the first time Comodo had me caught in a situation like this, so I´m considering getting rid of it for good this time. I just find that the Windows Security Package is not as user friendly, but I guess I could try to get used to it. Thanks!
    – Corey Hart
    Jan 13, 2022 at 22:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .