6

I know you can set the path where snapshots are saved in VLC Player's preferences. What I want is to save the snapshots not all in one fixed directory, but in the video's directory, provided of course that the video isn't on a read-only medium like a DVD.
I know this is possible, but I forget which symbol I should enter in the save path.
Any ideas?

2 Answers 2

10

In Preferences --> Video --> Video snapshots
Change directory to .
Like so:

enter image description here

6
  • 4
    I'll be damned, learned something today! Thanks, this has been bugging me subconsciously for a long time :)
    – MiG
    Jan 7, 2022 at 14:02
  • 4
    Yeah, that's it. How could I ever forget? Thanks a bunch.
    – stevenvh
    Jan 7, 2022 at 14:03
  • Note this doesn't work for Mac.
    – Tetsujin
    Jan 7, 2022 at 14:10
  • 2
    @Tetsujin I'm guessing, will a ./ work on Mac instead? Jan 7, 2022 at 14:16
  • 3
    @SaaranshGarg - Not seeing any variation on that kind of theme that works. Unless it's an actual address it does nothing. Remove it & it reverts to its default. It won't even accept Mac-shorthand for 'user' ie ~/anything, it demands a full address or none.
    – Tetsujin
    Jan 7, 2022 at 16:40
1

My findings when using "." as directory in VLC snapshot settings with VLC 3.0.20 on Windows 11 and VLC 3.0.16 on Linux Mint 21.2

When starting VLC directly from the command line (Windows) or terminal (Linux Mint) with a video file as argument, it uses the startup/current directory as working directory. This also seems to be the case on both platforms when using the --started-from-file option.

Using the dot "." will work on Windows when using the VLC desktop version on Windows and using explorer to start videos though file associations (double clicking on a video file) . Explorer will start VLC with the directory of the video file as working directory.

Using the dot "." on Linux Mint using nemo does not work, changes have to made. Instead of launching vlc when clicking on a video file using nemo, a script file that changes into the directory of the video file needs to be launched first:

  • sudo edit the file /usr/share/applications/vlc.desktop and find the line starting with "Exec" around the end of the file.
  • change /usr/bin/vlc to /usr/bin/vlccustom in that line, save file, quit editor.
  • cd /usr/bin
  • create the script file sudo touch vlccustom
  • make it executable sudo chmod +x vlccustom
  • sudo edit the file vlccustom
  • add the lines shown below, save file and quit the editor
#!/bin/bash

echo "$2"
DIR=$(dirname $2)
echo "$DIR"
cd "$DIR"

/usr/bin/vlc --started-from-file $2

Note: The vlc.desktop file setting Terminal =true or =false comes in handy while testing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .