21

Earlier, when I would want to a view a file, Firefox would prompt me the app to open the file in, and then save the file in the \AppData\Local\Temp folder, and open it. As the Temp folder would be cleared, the downloaded file disappeared, as expected.

Now, when I do it, the file is downloaded to the Downloads folder, and thus clogs up space forever. How can I restore performance so that temporary downloads always go to the temp folder?

Referring to figure below, which presents the popup when I download a file, how can I force Firefox to download the file to the Temp folder when I choose option 1: 'open with Word'

Download Popup

The environment variables for my PC point to the AppData\Local\Temp location, and hasn't been modified recently.

3 Answers 3

28

For Firefox 102 or later you can go (just type in the address bar) to the (unsupported, at-your-own-risk) configuration page about:config, search for:

browser.download.start_downloads_in_tmp_dir

and click at the sideways arrows to change it from false to true, and the behavior will be back to the expected, no restarting necessary.

Source.

A minor unwelcome side effect of this setting seems to be that trying to download a PDF results in first downloading it to tmp and opening it in the browser — from where it can then be downloaded to the desired location.

0
4

https://www.ghacks.net/2021/08/04/a-close-look-at-firefox-91s-new-file-download-opening-behavior/

About halfway down the page is the solution, but in case posting links to other sites is not okay here:

Load about:config in the Firefox address bar.

Confirm that you will be careful on the warning page.

Search for browser.download.improvements_to_download_panel.

 Set the value to TRUE to enable the new download behavior.
 Set the value to FALSE to disable the new download behavior.
2
  • In Firefox 103 (Ubuntu) it doesn't seem to work.
    – stafusa
    Aug 4, 2022 at 9:42
  • Since about FF102 it has been replaced by browser.download.start_downloads_in_tmp_dir (if that still doesn't work, make sure in the options not to have that file type set to save automatically).
    – mirh
    Jan 16 at 17:04
3

How can I restore performance so that temporary downloads always go to the temp folder?

Open Firefox (I am there now) and go to the 3 top right bars (Settings).

Open Settings, scroll down the right side of settings until you come to Downloads.

Change the download location to what you want. Restart Firefox and then test.

You can also enable the setting to have it Prompt you. That is useful.

However, there is just one download folder setting which will be used for both "permanent" and "temporary" files. That is why I always Prompt.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .