I am running Windows 7 (64 bit) Pro. Whenever I try to install anything from a .msi file, I always receive the error:

"Error reading from file <path>/setup.msi.  Verify that the file exists and that you can access it."

I've tried opening a command prompt as administrator and loading via the installer (msiexec) directly but still receive the same error. I have administrator privileges and I checked the permissions on the file and I have full permissions. I believe this is a 32 bit application so I am wondering if that has something to do with it. Any help is appreciated.


Sorry for posting this. After hours of trying to figure this out I just did a little more research and got it. Apparently my user was the only user with privileges on the folder and file containing the .msi file. I added the SYSTEM user to have read and execute privileges on the folder containing the installer file and voila...it works and installs now.

| improve this answer | |
  • Had the same problem, installer couldn't read from %temp%\folder\installer.msi (%temp%=C:\Users\username\AppData\Local\Temp). Added full rights for user SYSTEM on %temp% folder and installer ran just fine. – Tedd Hansen Jul 3 '14 at 8:40
  • You should mark this answer as correct. – Tedd Hansen Jul 3 '14 at 8:41

Process Monitor should indicate what file it is trying to access and if there are permission problems.

You could also check the event log and the most recent *.log files in the C:\Windows\Temp folder.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.