0

I am running the following docker image (among others) at my home server: ghcr.io/linuxserver/bookstack

Everything is working flawlessly, but I have realized of something quite odd.

I use restic to backup the data of my Docker containers. To avoid inconsistencies in databases contents of some of my containers I stop everything, run the backup command and then start all the containers again.

The thing is that the ctime attribute of the files stored in the volume managed by the Bookstack container gets immediately changed when the container starts, I do not know exactly why, because files contents are not modified nor the stat command shows any other attribute change except for ctime. This makes backups much more slower (more than 30 minutes against 40 seconds if I use the --ignore-ctime flag of restic).

Other containers that I run do not do that.

My question is: why this is happening? Or: how can I find out which attribute is being updated in the files and thus ctime?

As I said, I can quite of solve the problem with the --ignore-ctime restic flag, but I would like to know what is going on with that image.

Any clue is welcome.

Thanks in advance for your help.

1 Answer 1

0

This is more a question for the image creator than for docker or restic. A common cause I see for changing timestamps is a recursive chown. It looks like that image has a few in various scripts, including this one on the config folder:

# set permissions
chown -R abc:abc \
    /config

https://github.com/linuxserver/docker-bookstack/blob/dce5e3c92390ec99624a744fbe8c83cfff395461/root/etc/cont-init.d/50-config

1
  • Hi @BMitch. Thanks for the prompt response and sorry for the dumb question. It is true that it was more a question for the creator of the image, but I was so blinded by the results I was observing with stat (no changes except for ctime) that I did not think that this could be the issue. Anyway, I hope this question can be helpful for anybody with a similar problem. Thanks again for your help!
    – Toni
    Jan 13, 2022 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.