18

Firefox updated to version 96.0 on my Windows 11 PC. It worked fine for a few days, but now it doesn't load any pages anymore (moving dot in tab). The Internet connection is fine; I'm writing this in Edge.

I tried restarting Firefox, and also rebooted the PC, to no avail.

What's happening here, and how can I solve it?

5
  • 3
    That's interesting: Firefox stopped working for me about 15 minutes ago both on my Linux computer which I was using at the time and on Windows 10 that was turned off. Other programs were working just fine. Now everything is back to normal.
    – gronostaj
    Jan 13 at 9:22
  • @gronostaj -- What FF version(s) do you have? Jan 13 at 9:26
  • The "Technical Description" for the Firefox update to 96.0 (from 95.0.1) in Software Updater on Ubuntu MATE 20.04 is this. Jan 14 at 14:19
  • The (forced) update today to Firefox 96.0 on Ubuntu MATE 20.04 (Focal Fossa) didn't cause any problems. Jan 15 at 20:14
  • Re "doesn't load any pages anymore": Even if it is all of them, can you provide some examples in your question? Jan 15 at 20:23

4 Answers 4

27

Firefox 96 (and possibly other versions, including ESR) is experiencing a bug at the moment of typing (09:30 UTC, 13-jan-2022) in the HTTP/3 stack that causes the browser to stop loading any page. A workaround for this bug is to disable HTTP/3 entirely:

  1. go to about:config
  2. set the setting network.http.http3.enabled to false
  3. Restart Firefox
2
  • 9
    The bug is marked as "Resolved" as of 11:03 GMT, 2022-01-13. A comment on bugzilla.mozilla.org before it was unbroken says "It affects all Firefox versions, even ESR, so the suspicion is that an external service updated (at exactly 12AM PST), specifically one that may load balance for our telemetry/update/blocklist servers." Jan 13 at 11:52
  • 1
    I had this problem with 95.0b5 and 93.0b6 myself, although the crash reports are mostly for 96, 95.0.2 and 91.5.0esr, those presumably being the most popular installed versions.
    – Neil
    Jan 14 at 17:00
3

I don't know if this the same problem I had earlier today, but the following procedure worked for me. It was hinted at in the Mozilla help files.

  1. Go to Windows settings.
  2. Locate the pane where the firewall settings are managed.
  3. Find the pane where you can control which programs are allowed to go through the firewall.
  4. Find Firefox from that list. Remove its checkmark. Click "Save".
  5. Go again to that list. Put the checkmark in again. Click "Save" again.

Sorry, my screen caps will likely be unhelpful, because my Windows is in Finnish. Judging from the appearance of a few key screen caps this page explains the procedure. This page sounds more official given that it is a Microsoft site.

Eagerly await for an explanation of why this is needed/helps. Because this was in an older help file in Mozilla, something similar may have happened in the past. Mozilla raises the suspicion that security software may be the cause.

6
  • I discussed the problem with a more knowledgable friend. He had a plausible sounding theory that this remedy would help, if the update failed to make itself recognizable to the firewall. That sounds a bit unlikely given that this is not exactly the first FF update. Another theory was that my procedure was totally ineffective, but just happened to coincide with something getting fixed at Mozilla's end :-) Jan 13 at 19:19
  • 1
    Another theory is that some cargo cult performance bridged the time interval during which some service (blacklist or whatever) FF relies on was unavailable which stupidly stalled all page loads. When it became available again after a few minutes everything worked again, without updating (I don't think my FF installation updated, it claims to be from Dec 19). "Please, FireFox, while you are waiting for a response on this core use some of the many other cores to load my page." Jan 14 at 9:52
  • LOL @Peter-ReinstateMonica! FWIW mine was updated to version 96 yesterday morning, so the first theory did not sound entirely implausible :-) Jan 14 at 10:04
  • Can you link to those help pages? Jan 14 at 12:22
  • 1
    Thanks for the tips on how to improve the post @PeterMortensen. Jan 14 at 16:52
3

As we now know, this bug was two bugs really, where the first resulted by being case-sensitive while parsing HTTP headers when the specification says they are not.

This occurred in the implementation for the HTTP/3 stack only.

C.f. Mozilla Firefox bug database -

a server responded with "content-length:" instead of the ubiquitous "Content-Length:" header

Here is the source code commit that fixed this (scroll to the bottom to see the fix).

The second bug was that there was no logic to continue implemented if the "Content-Length:" header could not be found in the response. So the continuation was to "look again for the header that could not be found" and "again" and "again" ... resulting in an endless loop.

You can see the discussion further down in the same entry of the Mozilla Firefox bug database. The fix for this bug is seen here.

So these bugs were lurking for quite some time now - they just got triggered now. It is assumed that a big cloud provider changed their load-balancing proxies to return lowercase headers at some point.

This would explain why there was no update of Firefox involved and it even happened to far older versions like 91.0.

Some said disabling telemetry fixed it for them, so it may be that just Firefox sending the open-tabs-count or the OS version to Mozilla's servers could have triggered this bug without any user-entered website being involved.

1
  • Telemetry triggered the bug because it ran over google's load balancer. While disabling appeared to fix the problem, it wasn't a real fix as it'd just trigger as soon as the user visited any other site that used http/3.
    – MMM
    Jan 15 at 22:05
-1

I had the same problem a few days ago. Firefox would not load any websites, while Chrome worked just fine. I had to change the way Firefox connects to the Internet:

  • SettingsNetwork SettingsSettingsNo proxy.
  • Restart Firefox.
  • Then it worked fine again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.