I started an installation of the Xcode 4 developer's preview last night before going to bed. When I woke up, the installation had popped up a message saying to close Xcode first (doh!). I did so, but whatever script had displayed the message seemed to have hung because the (uncancellable) message wouldn't disappear, and the installer wouldn't progress.

After force quitting the Installer app, the message above was still showing, so I restarted my MacBook Pro and then tried the installation again. This time it wouldn't even start, instead showing one of those candy-stripe activity bars and the message:

Waiting for other installations to finish

At this point, I'm stumped. There are no other installations in progress, so there must be some artifact left over from the interrupted install that's gumming up the works. But what?

  • This might sound a bit madcap, but in the past I've found that quiitting the iPhone simulator can unstick these installs. I suspect theres some sort of lock that only allows one installer at a time, and the iPhone simulator holds that lock closed so it can install apps into its own space. Remember the iPhone simulator just runs regular intel apps but with a different ABI and wrapped in a chrooted ios-like environment, so I guess its sharing the install lock with the OS
    – Shayne
    Commented Mar 26, 2019 at 1:35

6 Answers 6

  1. sudo rm /private/var/db/mds/system/mds.install.lock
  2. reboot or sudo killall -1 installd

Chances are that a previous installation hung and the lock was never cleaned up.

  • 9
    it's weird how many times I have to refer to my own answer here... that's such an obtuse path.
    – bluesmoon
    Commented Apr 26, 2012 at 14:45
  • 3
    Obtuse indeed. Worked for me without having to reboot--thanks much.
    – funroll
    Commented Oct 28, 2012 at 6:57
  • 2
    The file was named simply mds.lock for me, but otherwise this worked without reboot, thanks!
    – mVChr
    Commented Oct 29, 2015 at 16:55
  • 16
    I had both mds.lock as well as mds.install.loc, which I removed, but in addition @tantrix's solution (sudo killall -1 installd) was needed to avoid the reboot. Commented Dec 9, 2015 at 11:53
  • Note: worked for me without the 'reboot'
    – Daniel
    Commented Jun 21, 2018 at 19:43

When an installation happens a daemon installd runs. Killing a leftover installd should allow another installation to happen (and will kill any new ones that are waiting for the defunct one to finish). So,

sudo killall -1 installd

Nice aspect of this is you won't need to reboot.

  • 1
    Thanks. There were two installations pending. Both finished right after this command Commented Jan 24, 2016 at 23:49
  • 1
    Thanks, this should be the right answer Commented Nov 2, 2019 at 16:30
  • 2022 - Used on macOS Monterey to kill a stuck Xcode App Store install that persisted through reboot. Allowed me to run the installer manually. Thanks. Commented Oct 1, 2022 at 0:23

I had the same problem for no apparent reason and found a couple of solutions suggesting deleting some files - but nothing helped (at least was not enough). Eventually force-quitting the installer with activity monitor and then restarting my Mac did it and after the restart the installation completed fine.


Simply just check that no Applications are downloading in the App Store because I had iMovie downloading in the background and I didn't notice until later. After that I just cancelled the iMovie installation and the other installation downloaded within seconds.


Is there a previous Xcode installation on your computer? If yes maybe you should try and uninstall it first. Good luck..

  • 6
    Bad advice - Apple even expressly allows multiple Xcode installations to exist. I see your reply was first, so you made a blind guess, and I'm just saying: Uninstalling other software on OSX is usually not the solution - that's contrary to Windows, where this used to be rather the rule. Commented May 11, 2012 at 9:10

When i try: sudo killall -1 installd I need a password to continue. Also activity monitor can shut down any other installers running that was the way it worked for me...

  • You are correct, sudo runs via admin privileges and needs a password. Commented Jun 17, 2020 at 14:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .