0

For unknown reasons, the wget version provided by Linux Mint 20.3 gave me a segmentation fault error.

That's why I replaced it with the last version:

wget https://ftp.gnu.org/gnu/wget/wget-latest.tar.gz
tar -xf wget-latest.tar.gz
cd wget-1.21.2
./configure
make
sudo make install

The last step (sudo make install) has overwritten the version of wget that came with Linux Mint. I cannot remove the deb package wget because of dependencies with Cinnamon.

Future OS updates may overwrite the version of wget compiled by me.

What do I do in such cases?

I tag the question with "Linux Mint" and "Ubuntu" because the problem is similar. In fact, not only Cinnamon depends on the wget package, but also Google Chrome.

1 Answer 1

2

You could have specified a prefix like "/usr/local" with ./configure, and put /usr/local/bin first in your PATH.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.