0

I am trying to open Bash in Windows 11. However, I can't get it to open. The best that happens is it opens and then immediately closes (in a fraction of a second).

I understand there is already a question posted regarding opening bash in Win 10 Anniversary. I tried those fixes, but they were not effective. Since Windows 11 has significant changes (especially compared to Win 10 feature updates), I argue that it deserves its own post.

The steps that I have taken:

  1. Turn on developer mode (significantly different in Win 11. I followed this guide on How to Enable Developer Mode in Windows 11.
  2. Turn on WSL (following this guide to Enable Bash on Windows 10) and start Bash.

I have gone through these steps several times, but had no success. In addition to following the instructions set out about, I have:

  • Restarted my computer many, many, times.
  • Uninstalled/reinstalled WSL from 'Turn Windows features on and off' several times.
  • Tried the solution set out in the parent question (opening in Win 10) and tried enabling legacy console. I have tried with legacy on and off, without success.
  • Tried typing the command (in CMD prompt), "bash". Another post about Bash opening and closing mentioned (first answer by '-Mr Happy') about typing "Bash" into CMD prompt. I tried that and CMD responded with "Windows Subsystem for Linux has no installed distributions. Distributions can be installed by visiting the Microsoft Store: https://aka.ms/wslstore". This took me to the Windows Store to install a program to "Run Linux on Windows". As such...
  • I installed the Ubuntu app. I had no idea what this would accomplish, but I was happy to try anything at this stage. When opening the Ubuntu app, it just opens a shell window (not sure about terminology) which says "Press any key to continue..." (closes the window immediately). I don't know what this was supposed to do, but I basically uninstalled/reinstalled WSL just to check.
  • Additional to -Mr Happy-'s advice above, he suggested to check the contents of the folder: C:\Users%USERNAME%\AppData\Local\lxss. At no point was the folder 'lxss' created. I imagine this is why bash.exe never worked. Nothing that I did caused the folder to be created.

All of this is to install zsy on my computer. I appreciate any advice on the matter.

5
  • Have you installed a distro through the windows/microsoft store? Bash is not part of windows (even 11). Bash comes with a distro (or multiple) that you install through WSL. WSL does NOTHING on it's own but allow you to install Linux distros. Don't give up! WSL is b@d a$$! :) Jan 18 at 5:08
  • S**t.. I should have read your post better. Your problem lies in getting a distro installed. Try a different one. I myself run ubuntu and debian with ZERO issues. If that fails, you can skip the rest of your problems and jump right down to the fact that you can't get a distro to install from the ms store. Jan 18 at 5:10
  • WSL hasn’t required Developer Mode be enabled for more than 3 years now.
    – Ramhound
    Jan 18 at 6:07
  • @Ramhound, does that mean I can just switch it off without issues? Jan 18 at 16:34
  • I know next to nothing about your system, what I can tell you, is that Developer Mode is NOT required for WSL on any supports version of Windows 10 or any version of Windows 11.
    – Ramhound
    Jan 18 at 16:45

1 Answer 1

2

In keeping with the parent question, through the assistance of Señor CMasMas, I may have found the solution to my own question.

Below is the journey that I took to reach the solution. Short version: update to WSL2 to enable Bash/Ubuntu/Debian.

  1. I downloaded Debian. Debian didn't install, but it told me to go to Docs: Install WSL.
  2. Through a series of PowerShell code typed into CMD Prompt and various web searches, I stumbled upon the idea of changing to WSL 2.
  3. In doing this, PowerShell informed me that I needed to enable the virtual machine feature.
  4. Then, I returned back to change to WSL 2 (step 2 above) and then Bash/Ubuntu/Debian worked fine.

Thank you for your assistance.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.