0

So recently, I was trying to "do-release-upgrade" of Ubuntu 20.04 in my 18.04 instance. But while upgrading, I accidentally closed my ssh connection. Then I tried to reconnect but I got "connection refused" message and couldn't connect. Also I can't connect to http server running.

I set my ssh port to 22818, but it seems like the iptable rules has been reset while upgrading. I checked nmap port scan and the only port opened is 22. But the problem is... the instance has "endlessh" installed which prevents ssh login to port 22. So I cant even connect to port 22.

I tried cloud shell console connection but it keep saying incorrect login.

How can I solve this problem?

1 Answer 1

0

SOLVED!

I noticed that FTP was running and the port was open. It kept saying login details are incorrect. I booted this instance to maintenance mode with cloud shell and allowed anonymous mode and I could get all files.

I backed up those files to another temporary instance and restored to fresh one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.