I have an issue with my keyboard (Japanese Keyboard but I am sure it has nothing to do with localization). Whenever I use my Del key (delete key) that isn't in the numpad, it does nothing. And when I am editing a text and use the arrow keys (Left and Right), the cursor (caret) moves to the beginning of the line or to the end respectively.

I had that issue in the past I don't recall what key combo I should press to fix this.

My keyboard is a Sanwa SKB-BT22BK (I am pretty sure it's not a hardware or keyboard firmware issue but I'm writing the reference just in case).

The OS is Windows 10.


1 Answer 1


I had a look on the picture of that keyboard and to me it seems that the Fnkey is pressed.
Meaning when you press Fn + Del (non keypad) it will enable the scroll lock. When you press Fn + Left arrow it will do "Home". The Fn key basically does the function mentioned in the blue text.

I didn't see a key for the Fn lock or to toggle the Fn key but it seems the most likely case.

In the manual it even states:


Translated this means:

Press to activate the function printed in blue

  • You are right. Fn was somehow locked which is unusual. I'd never noticed the blue "Home" and "End" text on the arrow keys. it would have been a hint I guess (if I had).
    – Paiku Han
    Jan 25, 2022 at 15:30
  • 1
    @PaikuHan sadly I'm not very good in Japanese so I'm currently unable to try and find how to disable the toggle. Also if my message solved your question, please mark it as answer for future users looking for this.
    – VarmintLP
    Jan 25, 2022 at 15:56
  • you solved the issue. I don't thing there is a toggle lock thingy on the keyboard. Like I said this would be the second time it happened (last time was way back). As soon as I pressed "Fn" the issue got fixed. This could be caused by a firmware issue since sometimes after a short periode of inactivity, the bluetooth on the keyboard turn itself off. Also I've played a lot with the "Fn" key trying to figure out a few things before I built my own keyboard. Note that I did mark your answer as The Answer before I post my first comment.
    – Paiku Han
    Jan 25, 2022 at 22:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .