12

My computer was recently upgraded to Windows 11 and my default program for JPEG (.jpg, .jpeg) was changed from my preferred program of JPEGView to Photos (Windows default app). Photos takes a while to open and JPEGView opens much more quickly. I would like to change it back to JPEGView. However, there are no options in the "Default apps" settings page for JPEG images and file types.

If I scroll all the way to the bottom to change it for the specific .jpg file type, it does not exist.

"jpg" does not work

".jpg" does not work

"*.jpg" does not work

If I go through all of the apps, including "Photos," that might be the default, JPEG is not an option.

JPEGView Defaults

Photos Defaults

IrfanView Defaults

Paint.NET Defaults

Is there another settings page that would allow me to change this default? If Microsoft "hid" this, or if this is a bug, is there a registry setting that I could modify to change this?

Some details about this computer: I am the administrator, it is not connected to an Active Directory domain, it is running as a VM that I remotely connect through either a) Spice, or b) Remote Desktop

EDIT

Selecting "Open With" does not provide an option to set the default. If I choose another app, it opens with that app, but only once. It does not set the default.

The "Open With" menu

The "Open With" "Choose Another App" dialog

EDIT 2

Digging around, I've discovered that this applies to PNG files as well. With other file types, such as TIFF and WEBP, there are options for setting the default within the Windows Properties dialog, Open With, and Default Apps. With PNG and JPEG, the button for "Change Default" does not exist in the Windows Properties dialog. It seems like these file types are "locked down" and are allowed to be changed. The question is, "is this a bug or a feature?"

EDIT 3

I just spoke with a co-worker who also upgraded his Windows 10 VM to Windows 11 and he does not have this problem. He is able to set the defaults for JPEG and PNG files.

8
  • Navigate to the file you wish to open. Right click and select Open With. Can you open with your App? If so you may, in that selection, set it to default App.
    – John
    Jan 25, 2022 at 20:30
  • There is no option to set default in the Open With Dialog. I will get screen shots and add it to my post.
    – mawcsco
    Jan 25, 2022 at 23:03
  • It is possible Windows 11 will not all that App as a default App.
    – John
    Jan 25, 2022 at 23:06
  • That's not a good conjecture. First, JPEGView is the default for PNG files. So, I know the app is allowed. Second, it doesn't allow me to set ANY app because there are no options for the JPEG file type anywhere in the settings.
    – mawcsco
    Jan 25, 2022 at 23:15
  • “Is there another settings page that would allow me to change this default?” - No; You can probably solve this problem by creating a key for those two file extensions. You can do that by finding one of the file extensions that do exist in your registry, exporting it, then edit and import. I suggest using .tif as the template.
    – Ramhound
    Jan 26, 2022 at 1:22

3 Answers 3

15

I finally decided to search Google in a Guest profile and I added -"how to" to my search and was able to find some answers. It looks like there may be a bug in the Microsoft Photos app that causes this issue.

  1. Apps and Features->Photos->"Advanced Options"->Reset (not Repair)

Apps and Features Advanced Options Reset

  1. Alternatively, open PowerShell as Administrator, run the following command: Get-AppxPackage Microsoft.Windows.Photos -AllUsers | Reset-AppxPackage

I chose the PowerShell option and I am now able to change the defaults for JPEG and PNG files.

Here are some links for reference:

Widows 11 setting default program for jpg files is not working

Can't Change Default Apps Windows 11 (OS Build 22000.120)

4
  • 1
    Worked for me too. Used the interface method. Only note, I didn't have the "Apps and feature" menu in Settings. To find the "Reset" button I had to search for Microsoft Photos in "Installed apps", click the three dots on the right and then "Advanced options"
    – il_mix
    Jan 19, 2023 at 11:27
  • I installed the Photos app (uninstalled it weeks ago), then run the PowerShell command above to reset the Photos app. Afterwards I was able to right-click a JPG file, select "Open With", and then there was (finally!) the "Always" button next to the "Just once" button.
    – miguno
    Jul 29, 2023 at 20:14
  • Saved my day! Thanks. How could one figure this out by themselves...
    – Shaohua Li
    Sep 12, 2023 at 16:54
  • Same issue as @il_mix but this worked otherwise!
    – aslum
    Dec 13, 2023 at 6:31
0

In my case I used PowerShell command mentioned by @mawsco, BUT first I needed to install Microsoft Photos app from the store. While it wasn't installed the reset command would not work, and trying to use Choose another app from context menu would give me a slightly different (newer?) UI showing only "Just once" button. After I installed the Photos app, opened it, made sure it opens JPEGs, I ran the PowerShell command and then I tried context menu Choose another app option. This time there was an "Always" button available.

Just so many hoops to jump through in Windows 11 as if Microsoft wanted that people who worked with this software since Win 3.11 felt lost again...

1
0

Photos uninstallation:

Run Powershell as administrator Paste and extract this code:

get-appxpackage *photos* | remove-appxpackage

Photos Reinstallation:

Run Powershell as administrator Paste and extract this code:

Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
1
  • If reinstallation via PowerShell fails with a bunch of error messages, go to Microsoft Store, search for "Microsoft Photos" there and install it via the app store, then run reset as suggested above, then uninstall this idiotic software. Jan 19 at 0:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .