0

This INTL layout appears suddently from nowhere:

enter image description here

And it is not reflected in settings, only my normal layout:

enter image description here

enter image description here

So to remove it, I have to add it first using "Add a keyboard" (this costs me a lot of time and concentration because there is no search field in dropdown used to select layout options):

enter image description here

and then remove, and it disappears for some time 🤪

So obviously it is bug. Question how to fix it?

PS: Why it is so important: US INTL is especially annoying for me as a Software Developer because it does not allow to enter single quote characters so I never would like to see it


On the next day after removal INTL appeared again, I executed Get-WinUserLanguageList immidiately once I saw INTL in taskbar again:

PS C:\Users\ivan> Get-WinUserLanguageList


LanguageTag     : en-US
Autonym         : English (United States)
EnglishName     : English
LocalizedName   : English (United States)
ScriptName      : Latin
InputMethodTips : {0409:00000409}
Spellchecking   : True
Handwriting     : False

Then, as always I have to go to "Add a keyboard" select "United States International" in Options -> Keyboards to remove it. Now WinUserLanguageList is:

LanguageTag     : en-US
Autonym         : English (United States)
EnglishName     : English
LocalizedName   : English (United States)
ScriptName      : Latin
InputMethodTips : {0409:00000409, 0409:00020409}
Spellchecking   : True
Handwriting     : False

And after that once I removed it from Keyboards

LanguageTag     : en-US
Autonym         : English (United States)
EnglishName     : English
LocalizedName   : English (United States)
ScriptName      : Latin
InputMethodTips : {0409:00000409}
Spellchecking   : True
Handwriting     : False

So when I see fake INTL keyboard in taskbar, in fact Get-WinUserLanguageList does not show 0409:00020409

Here is My Windows version:

PS C:\Users\ivan> [System.Environment]::OSVersion.Version

Major  Minor  Build  Revision
-----  -----  -----  --------
10     0      22000  0

From specs:

Edition Windows 11 Pro
Version 21H2
Installed on    ‎12/‎6/‎2021
OS build    22000.438
Experience  Windows Feature Experience Pack 1000.22000.438.0
5
  • Make sure the icon is hidden so that the only way it gets activated is to click on the task bar up arrow ^ . I do not see it this way. I have not see a definitive way of getting rid of extra keyboards in Windows 11 or 10.
    – John
    Jan 26, 2022 at 18:32
  • 1
    Can you provide us the output of Get-WinUserLanguageList by editing your question? We also need the Windows 11 version of this window
    – Ramhound
    Jan 26, 2022 at 18:45
  • 1
    Actually, International does allow single quotes, but you do have to follow each ' keystroke with spacebar [which I'm sure would also be annoying if you weren't expecting it]
    – Tetsujin
    Jan 26, 2022 at 18:45
  • @Ramhound thanks, added, today issue was reproduced again 😟 Jan 27, 2022 at 15:36
  • I am wondering if this is a setting that is being pushed from e.g. a Microsoft account based on settings used on another device. (cloud-based roaming profile)
    – Yorik
    Jan 27, 2022 at 15:47

0

You must log in to answer this question.

Browse other questions tagged .