I have a PC with Windows 11 and the Edge browser. I want to get rid of the "Rewards" on the new tab page.

If you search the internet for "microsoft edge disable rewards" you get multiple websites explaining to you how to use the settings of the browser (duh!). But this setting does not work for me: The rewards badge is still showing in the "new tab" page (top right next to the settings-cog): Rewards badge still showing on new tab page but setting disabled My PC was upgraded from Windows 10. On a different PC (new Laptop) it works as expected (disabeling the setting hides the rewards badge). Maybe this is is the source for the error?

I have tried the following on my PC (to no avail):

  • Enabling the setting, restarting edge and disabling it again.
  • Deleting %USERPROFILE%\AppData\Local\Microsoft\Edge and starting Edge (this leads to Edge starting the "New install" greetings etc. but does not help the rewards badge: the setting is still not effective)
  • Searched the internet for group policies concerning Edge + Microsoft Rewards (there is Edge (Chromium): Show Microsoft Rewards experiences, but it doesn't seem to exist any more [for my machine])
  • Searched the internet for regedit keys, added and disabled them (HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge->ShowMicrosoftRewards: 0)
  • Searched Edge://flags for "reward": no entries

Is this a known bug of Windows/Edge? Are there any other ways to disable Microsoft Rewards for Edge?

  • Is your Microsoft Account actually an Azure AD account? Windows 11 Home or Professional?
    – Ramhound
    Feb 8, 2022 at 18:05
  • 3
    Since Edge has advertising "baked in", you might consider other browsers. Feb 8, 2022 at 18:20
  • 2
    I agree with @DrMoishePippik. Edge was a good enough substitute until they started adding bulk. Switch to Chrome, Vivaldi, Firefox or something else.
    – LPChip
    Feb 8, 2022 at 18:24
  • Chrome by default will link to your Google Account. Firefox has whatever their synchronization account is called. The rewards balance can be hidden. However, if you are unhappy with the connection to your Microsoft Account, the simplest way is just don't synchronize your profile to a MS account. This will efficiently hide the balance.
    – Ramhound
    Feb 8, 2022 at 18:31
  • If you hover the cursor over this entry, do you see a 3-points icon? Click it to see a menu where you may suppress the entry.
    – harrymc
    Feb 8, 2022 at 21:06

3 Answers 3


After much trial and error the only thing that helped was resetting the entire Edge installation: uninstalling via cmd and reinstalling (I don't remember the exact steps; I followed various instructions I found via google).

In the end I followed one of the commentors' advice: I ditched Edge because it got bloated.

  • Click the three dots ... top right and select 'settings'
  • Under 'Your profile' select 'Microsoft Rewards'
  • Disable the button to earn 'Microsoft Rewards'
  • Restart Edge

No rewards icon top right

  • That's exactly what is shown in the screenshot in the question itself and did not work.
    – genericFJS
    Sep 13, 2022 at 22:54
  • 1
    I didn't look carefully enough at your question I am sorry. The above procedure did work for me on a new build of Windows 10 yesterday. Maybe MS have fixed? Sep 14, 2022 at 3:23

I chose to opt-out of the Microsoft Rewards program and it disappeared from the Profile selector etc.
Just be aware that you'll lose any accumulated points.


Which in turn leads to:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .