1

I have been struggling with this for 4 days now and can't seem to solve it.

I am connecting to work network from home via windows 10 vpn. What I am trying to obtain is to only route my RDP connection through the vpn and all other traffic through local network. I have gone through and attempted tunneling and adding different specific static routes but I have had no luck. I have tried adjusting metrics. When tunnel is enabled for the VPN connection I can not connect via RDP when its disabled it works and all traffic goes through VPN.

Is there something specific with RDP that I am missing?

edit:

Here is the route table for when VPN is connected and no split tunneling:

enter image description here

And here is the table when vpn is connected but split tunneling is enabled.

enter image description here

6
  • edit your question to add your route table, and an overview of the network layout. Feb 10, 2022 at 16:34
  • what network or IP is it you are trying to reach by RDP? note that you cannot route traffic by application, so anything addressed to the remote network will go through the VPN, not just RDP traffic, but if the only think you send to the remote network is RDP, then it should work. Feb 10, 2022 at 22:29
  • according to resource monitor its accessing 172.28.40.42 Feb 10, 2022 at 22:55
  • 1
    interesting. the route to that network is more or less identical between your two screenshots. I assume that you are connecting by hostname since you had to consult resource monitor. that tells me that your dns hostname queries are not reaching the dns server on the other end of the vpn when you enable split tunneling. try RDPing by ip. does it work? Feb 11, 2022 at 1:09
  • Holy Crap thats it! Thanks alot all is working now! Feb 11, 2022 at 5:51

2 Answers 2

0

It sounds like you'll need to setup split tunnel VPN. That way you can have specific traffic routed through the VPN, RDP traffic in your case.

You can also refer to this article for an overview, and check specific documentation for the platform / setup your are using.

VPN Split Tunneling overview

0

In case anybody runs into this, I followed the article here : http://woshub.com/add-routes-after-connect-vpn-windows/ and this resolved my problem. I don't know if a second route to the dns server would allow me to RDP by machine name, but adding a direct route to the internal ip of the machine I was trying to connect to allowed me to split tunnel. I used the 192.168.1.123/32 (whatever the machine's internal ip is) style to route directly to a specific machine only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.