2

I created a user account that has no password.

When trying to login as that user from the Welcome Screen, Windows says:

Account restrictions are preventing this user from signing in. For example: blank passwords aren't allowed, sign-in times are limited, or a policy restriction has been enforced.

enter image description here

So, the question is:

  • How do I disable account restrictions preventing this user from signing in?
  • How do I allow blank passwords

System

  • Windows 10 Pro
  • Not domain joined

Local Computer Policy/Computer Configuration/Administrative Templates/System/Credentials Delegation:

Setting State Comment
Allow delegating default credentials with NTML-only server authentication Not configured No
Allow delegating default credentials Not configured No
Encryption Oracle Remediation Not configured No
Allow delegating fresh credentials Not configured No
Allow delegating fresh credentials with NTLM-only server authentication Not configured No
Remote host allows delegation of non-exportable credentials Not configured No
Allow delegating saved credentials Not configured No
Allow delegating saved credentials with NTLM-only server Not configured No
Deny delegating default credentials Not configured No
Deny delegating fresh credentials Not configured No
Deny delegating saved credentials Not configured No
Restrict delegation of credentials to remote servers Not configured No

Minimum password length of zero

In order to allow a user password to be blank, you need to make sure that the Password Policy Minimum password length is set to 0 (the default):

Local Computer Policy/Computer Configuration/Windows Settings/Security Settings/Account Policies/Password Policy:

Policy Security Setting
Minimum password length 0 characters

That lets you set a password that is blank. But that doesn't help you actually login, which gives the initial error that we're trying to solve.

Bonus Reading

3
  • techinpost.com/…
    – Gantendo
    Feb 18, 2022 at 0:21
  • "even more strongly enforced in Windows 11." - This is simply not true. I have a WIndows 11 21H2 VM with several users without a password.
    – Ramhound
    Feb 18, 2022 at 2:32
  • If this machine is connected to an AD domain, the simple answer to your question is what you want is not possible due to the current password policies configured by your AD Administration. If this is a local machine, you modify the relevant group policies to allow a blank password. Post a screenshot of these that provides the configuration of these group policies
    – Ramhound
    Feb 18, 2022 at 2:33

2 Answers 2

1

You mentioned that you have changed the Minimum Password Length setting, but there are other settings that could do this that you should verify.

  1. Open gpedit.msc
  2. Go to: Computer Configuration\Windows Settings\Security Settings\Account Policies\Password Policy
  3. Make sure all of the settings look like this:

Enforce password history: 0 passwords remembered

Maximum password age: 0

Minimum password age: 0 days

Minimum password length: 0 characters

Password must meet complexity requirements: Disabled

This should allow no password logins.

Alternatively, the way I know that works 100% of the time is to simply use a blank password when installing Windows. That will always work.

3

Using RegEdit, you can go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa and set the value of LimitBlankPasswordUse to 0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .