0

I start Linux virtual mashine via Wmware on Win 10 host. In Wmware Network settings I chose host only. After pinging VM from host I received answer "Request timed out". How can I solve this, I want to use my host offline and have posibility to ping my Linux VM?

1 Answer 1

1

In Wmware Network settings I chose host only.

VMware Host Only is an isolated machine.

Change your networking to NAT and Ping and Connections should work.

VMware Workstation 16.2.2 on Windows 10 Pro here with Linux and Windows Guests and pings and connection work fine.

You can use NAT or Bridged Networking for this.

..

Here is an informative article on host only guests.

Host only guests

In the default configuration, a virtual machine in a host-only network cannot connect to the Internet. If you install the proper routing or proxy software on the host system, you can establish a connection between the host virtual network adapter and a physical network adapter on the host system to connect the virtual machine to a Token Ring or other non-Ethernet network.

On a Windows host computer, you can use host-only networking in combination with the Internet Connection Sharing feature in Windows to allow a virtual machine to use the dial-up networking adapter or other connection to the Internet on the host system. See Microsoft documentation for information on configuring Internet Connection Sharing.

9
  • I try NAT option but pinging is not work. My host is Win10 pro and version of VMware Workstation Player is 16.2.1
    – zagortenej
    Feb 20 at 19:47
  • Make sure you pinged the NAT subnet (not your Host subnet). E.g. if host is 192.168.1.x NAT Subnet could be something like 192.168.78.x or like . You need to check that (check the IP of the Guest ifconfig).
    – John
    Feb 20 at 19:51
  • Also when you change the guest to NAT you should restart the guest.
    – John
    Feb 20 at 19:54
  • When I use command ipconfig on my win10 host I can see 3 IPv4 adress: 1. Ethernet adapter VMware Network Adapter VMnet1: IPv4 Adress 192.168...Subnetmask 255.255.255.0 2.Ethernet adapter VMware Network Adapter VMnet8: IPv4 Adress 192.168...Subnetmask 255.255.255.0 3. Wireless LAN adapter WiFi: IPv4 Adress 192.168...Subnetmask 255.255.255.0 When I use command ifconfig on my Linux VM i can see itnet 10.xxx netmask 255.255.255.0 Do I need some modification on my host network conf?
    – zagortenej
    Feb 21 at 7:27
  • You need to show the full IP address. 192.168..... does not help. These are internally routed IP addresses. Many many people use them. They are not exposed to the Internet.
    – John
    Feb 21 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.