2

as this not seem to be a Arch Linux specific question (and the arch forum can't help me) I try to ask a broader range of experts.

Since some days I can not access my kwallet anymore. Assuming the issue in kwallet first I now already know that the issue is laying deeper in the gpg system. I broke the problem down to not be able to access the secret keys anymore. While all secret keys are listed in gpg the access is not possible. Trying via CLI to decrypt a message with a secret key I get following error message

[kk@excelsior]$ gpg -vvv --output test.txt.gpg.txt --decrypt test.txt.gpg 
gpg: using character set 'iso-8859-1'
# off=0 ctb=84 tag=1 hlen=2 plen=94
:pubkey enc packet: version 3, algo 18, keyid AXXXXXXXXXXXXXX
        data: [263 bits]
        data: [392 bits]
gpg: public key is AXXXXXXXXXXXXXX
gpg: using subkey AXXXXXXXXXXXXXX instead of primary key AXXXXXXXXXXXXXX
# off=96 ctb=d2 tag=18 hlen=2 plen=182 new-ctb
:encrypted data packet:
        length: 182
        mdc_method: 2
gpg: using subkey AXXXXXXXXXXXXXX instead of primary key AXXXXXXXXXXXXXX
gpg: encrypted with 255-bit ECDH key, ID AXXXXXXXXXXXXXX, created 2021-03-12
      "user <[email protected]>"
gpg: public key decryption failed: No pinentry
gpg: decryption failed: No secret key

I tried to fix the missing pinentry by adjusting the ~/.gnupg/gpg-agent.conf as following:

default-cache-ttl 1
pinentry-program /usr/bin/pinentry-qt

###+++--- GPGConf ---+++###
debug-level basic
log-file socket:///home/kk/.gnupg/log-socket
###+++--- GPGConf ---+++### So 04 Okt 2020 22:33:36 CEST
# GPGConf edited this configuration file.
# It will disable options before this marked block, but it will
# never change anything below these lines.

I also reinstalled the pinentry package and ensured that the links are correct:

[kk@excelsior]$ ls -liah /usr/bin/pinentry*
45410269 -rwxr-xr-x 1 root root  369 Sep 19 20:53 /usr/bin/pinentry
45410270 -rwxr-xr-x 1 root root  75K Sep 19 20:53 /usr/bin/pinentry-curses
45410271 -rwxr-xr-x 1 root root  67K Sep 19 20:53 /usr/bin/pinentry-emacs
45410272 -rwxr-xr-x 1 root root  87K Sep 19 20:53 /usr/bin/pinentry-gnome3
45410273 -rwxr-xr-x 1 root root  95K Sep 19 20:53 /usr/bin/pinentry-gtk-2
45410274 -rwxr-xr-x 1 root root 159K Sep 19 20:53 /usr/bin/pinentry-qt
45410275 -rwxr-xr-x 1 root root  67K Sep 19 20:53 /usr/bin/pinentry-tty

Nevertheless no success. Still same error message. I cleaned the .gnupg directory in my home directory and imported the keys manually back but still same result. Looks like not the user configuration is messed up. Anyone with any idea?

0

1 Answer 1

1

Ah solution was posted in https://bbs.archlinux.org/viewtopic.php?pid=2025554 Reason seems to be a missing dependency to tpm2-tss.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .