4

Clicking the maximize button on the Windows command prompt does not help because the size does not increase. First of all, why is that?

Also, if you run this instead,

C:\Windows\System32\cmd.exe /k "mode 200,70"

you get a bigger Window. How does that happen? What does /k "mode 200,70" mean?

5

There are two parts to the answer.

The command shell option /k starts a new command prompt, runs some command (or a program, batch script, or group of commands) and the prompt remains rather than terminating.

In this case, the command is mode, which can be used to set the command prompt screen size/window buffer so it's 200 columns wide and 70 rows high.

Finally, if you want to change the default size of the command prompt, right click on the title bar, select 'Properties', and select the 'Layout' tab. You can set the size of the screen buffer and the window separately. The width should be the same for both. The screen buffer height setting determines how far back you can scroll.

| improve this answer | |
  • is that columns and rows or pixels? or are the columns and rows denominated in pixels? – Ungeheuer Jan 24 '17 at 1:10
2

/K | /C Are used to run a command after launching cmd.exe. Thus you are running the command/program mode. With mode there are several options the 200,70 is to change the display, but there are a few other options that can be used with mode.

As to the reason you can't maximize cmd.exe is the screen buffer. You should check out this site that will show you how to change it.

| improve this answer | |
0

Windows runs cmd.exe like most other Windows applications, in a window. Clicking on the maximize button "maximizes the window, but it's still a window.

Under earlier versions of Windows, the command prompt could be switched to full screen (as opposed to a window) by pressing ALT/Enter from within the command window. ALT/Enter again returns to windowed mode. I just tried it on my Vista desktop and got an error saying that my system doesn't support full screen mode, however, that may be because I have multiple monitors. My Windows 7 laptop appears to ignore ALT/Enter.

As for the cmd.exe switches, open a command window and type "cmd /?" or "help cmd" and you'll get lots of detail.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.