1

I recently purchased a replacement cable modem for my home internet. I was ready to upgrade my Cox cable internet from their 150 plan to their 500 plan.

  • Old cable modem was an older Arris Surfboard SB6141 docsis 3.0 modem.
  • New cable mode is a Netgear CM1000v2 docsis 3.1 modem from Amazon.
  • Old "plan" with Cox was 150/10, new plan is 500/10
  • Router setup is a TP-Link x20 mesh network with 3 "APs"

After activation with Cox support, the connection is operational, doing various speed tests though, I'm only getting around 100-150Mbps down instead of the advertised 500(ish). Upload is accurate at around 10Mbps.

I've tried various test sites, and tried via both wireless devices and wired laptop directly to the main x20 router. Whether on wifi or not, the tests never improved. Cox support also did multiple resets of the cable modem and we looked at the modem event logs and settings and they assert that everything looks right on the modem end.

What should I be looking at or troubleshooting to see what's wrong and why I'm not getting faster speeds after the hardware and plan upgrade with Cox?

1
  • What's the difference wired vs wireless? Mar 12, 2022 at 7:19

1 Answer 1

4

I dug into this on my side after getting off a long support call with Cox Support where they offered to send someone to my house to further troubleshoot but it was going to be a few days before a technician could be dispatched.

Troubleshooting steps:

  1. Checked the modem logs to verify the modem was operating at docsis 3.1 specs and in line with normal specifications and parameters. I followed this link for a deep dive: Signal levels on a DOCSIS 3.0/3.1 Cable Modem -- after looking through this I determined the modem appears to be operating properly. Cox pushed particular firmware and settings associated with the plan and modem since it's in their approved modem list. This was verified in the modem event logs.
  2. I then looked through the modem KB articles on Netgear's as well as the user manual and didn't find anything that was out of the norm.
  3. Next step was to start eliminating the variables. For me this meant to start with going hard wired for my testing. I tested multiple sites, verified the ethernet cabling was correct, and verified the laptop was working properly and connecting to my router at gigabit speed.
  4. Next I turned my attention to eliminating the router as the issue. This meant connecting my laptop directly to the CM1000 cable modem and testing. To my surprise, after doing this the speed tests were consistently in the 400s ranging anywhere from 400 to 500 mbps download rates.
  5. OK, so now I know it's not Cox and not the cable modem. Must be something with the TP-Link x20 router setup. I put everything back with the router plugged into the modem for further testing.
  6. ANSWER: Digging into the TP-Link x20 Deco app (where pretty much everything is configured, not via a web admin portal), I was able to determine my issue after checking the various settings. There is a QoS setting under "HomeCare" in the app that allows for some quality of service configurations. I had originally set up the router and clicked "streaming" for the QoS priority and it has a section for "Total Bandwidth" that calculates it either manually or automatically based on a speed test. The speed test here is within the Deco app itself and done from the router itself. Mine was set to automatic and was based on the last ran speed test in the app, which was from last year and based on the old ISP plan speeds (roughly 141down/9up). Because of this, the router was limiting connections to those speeds. I ran a speed test in the QoS menu and the router was getting 540Mbps down and 11 Mbps up.

The fix: set the router's QoS settings back to defaults (standard, with no device priority) and set the "total bandwidth" manually to 1024 down and 1024 up (the max settings for the router). After doing this, the speed tests on both wired and wireless were consistently around plan maximums averaging 480 down and 10 up.

I hope this can help others out there. If you upgrade to a newer plan or cable modem be sure and check your router's QoS settings if it has them and make sure your router isn't limiting bandwidth based on either the old plan's bandwidth or your own manual entries.

4
  • 2
    I have never had a positive encounter with QoS, and always keep it off. Not sure about everyone else.
    – Arctiic
    Mar 11, 2022 at 20:50
  • 1
    FWIW my local cable-based internet provider is known to alter (some say leak) QoS "tagging" to a flag which many routers will throttle aggressively. I think it is the DSCP CS1 flag (?)
    – Yorik
    Mar 11, 2022 at 21:30
  • 1
    @Arctiic When configured correctly, QoS works wonderfully - simply look at Killer's OpenWrt stock firmware on the Linksys WRT32X. QoS only comes into play if you have multiple devices accessing LAN or WAN at the same time with high throughput/saturating traffic - for example, with a Logitech smartphone puck remote (just the puck or along with the high end remote), you'll experience lag in commands without QoS if the LAN has a few devices accessing LAN or WAN at the same time pulling high throughput. You may also notice throughput lag when SSHing into the LAN remotely without QoS for SSH.
    – JW0914
    Mar 12, 2022 at 0:29
  • 1
    @JW0914 I was referring to the OEM QoS that come with most routers, which if I'm not mistaken, usually won't even come with any options to configure other than an on/off toggle (from the frontend, at least). I have 20+ devices on our network and pay for a 200MBPS plan (cable), but I do find there are still times I experience lag now and then, though I was hoping 802.11ax's MU-MIMO would alleviate that. I've never used a Linksys router before though, I don't know why I always end up buying Netgear routers, recently the Nighthawks.
    – Arctiic
    Mar 12, 2022 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.