I know this sounds pretty much like a question asked because of frustration, but i see no other solution but this one: i want to buy a new router and live with a stable internet connection. Some other people with other routers don't even seem to know that snow leopard has so much trouble with its airport connection.

(I have a d-link DIR-301 and really! tried everything out already)

thx so much for the response, here are more informations about the issues i have:

i have one of these white macbooks with snow leopard on it and noticed that i had no access to the internet, so i reset my router and it seemed to work for a day or so. But in fact it is breaking once in a while. Switching off and turning of the router works for me, but i know that it isn't save forever. Deactivating and activating the Airport is also a quick solution, but the internet connection only stays for half an hour. I have also tried to create a new environment and manually set the DHCP setting without any success. Updating to 10.6.3 didn't change anything as well.

i have a windows7 machine at home and its connection is a lot more stable. I can remember that my old G4 PPC eMac (on Leopard) also connected to the network without any problems, so i think it seems to be a problem with the new operating system.

are there any more tricks i can do? or can you recommend me a router that seems to work better with snow leopard? ( well of course i know that it should work with any router :( )

John, here are some answers for the questions you had:

DIR-301 is correct and i just double-checked this to be sure, it seems to be an older router you can't find at D-Link anymore because it is out-dated. The Firmware version is 1.02 and i will try to see wether i can update this later on.

The signal strength is pretty good, even compared to my other wlan-dongle i use on the windows-machine, so there is no problem with this.

I generally do not use any wired connection to the router on any machine.

  • 1
    I use Snow Leopard and haven't had any issues with D-Link, Motorola nor Linksys routers. And those are just the ones I know about. :) Basically, if there's a wi-fi connection, I just tend to be able to pick it up without any issues. (Assuming I have the credentials for it, of course.) – John Rudy Aug 2 '10 at 18:57
  • 2
    Like John Rudy, I've had no trouble with wireless connections on Snow Leopard. Between a couple different offices, home and relatives houses, I've hit at least ten different routers without problems. Can you give more information about what sort of problems you've encountered? Is it simply connecting? Configuration? – Doug Harris Aug 2 '10 at 19:01

Frankly, I'm pretty sure Snow Leopard has no (general) problems with any of the major brands of routers out there. Rather than look for a new router, I suggest you first spend a little more time figuring out what your problem is with the one you are currently using.

Some questions:

  1. The latest update for Snow Leopard is OS X 10.6.4. While I realize it probably won't help, you should still upgrade to that level anyway "just in case".
    Here are some links
    Mac OS X v10.6.4 Update
    Mac OS X v10.6.4 Combo Update

  2. What model of D-Link router are you using. Your answer says it is a D-Link DIR-301. I could not find this model listed on D-Link's web site. There is a DIR-601. Is that what you have?

  3. What is the version number of the firmware your router is using?

  4. What is the "signal strength" shown for your wireless connection if you press the Alt key while clicking on the Airport icon in the menu bar? (Just trying to get an idea whether or not you have signal strength problems).

  5. Just to be clear, you never try to use wired ethernet and wireless at the same time, correct? (This is in general confusing to OS X unless you know what your doing). (sigh) I believe I was wrong about this since I unwittingly tried it recently and there was no problem with connectivity. The situation I was actually thinking of was connecting to two different networks via ethernet & wireless. So long as both interfaces use the same network and same default route there seems to be no problem. Apologies for my mistake.

  6. Do you have the same connection problems if you turn off Airport on your MacBook and use a wired ethernet cable to connect to your router? Even if this is impractical I suggest you try it to see if it makes a difference.

To grasp at straws, I've seen comments in the firmware change logs for my D-Link DIR-655 about fixing problems with DNS Relay. Personally, I just turn off DNS Relay and add the two IP addresses for the OpenDNS servers to my router's configuration. OpenDNS is free and supposedly adds some extra "filtering" so I prefer using it rather than my ISP's DNS servers. Note that while you can create a free account as they urge you to do, you do not need to create an account to use their DNS servers.

Since I don't know for sure which D-Link router you are using I can't give exact instructions. What follows below is based on using D-Link's emulator for the DIR-601. (Most of their routers use a similar layout for there web configuration so this is probably close.)

To stop using DNS Relay

  • Logon to your router as admin and go to the NETWORK SETTINGS configuration. Uncheck the box for Enable DNS Relay under Router Settings.
  • Save the configuration changes.
  • Go to the INTERNET CONNECTION configuration page. Select Manual Internet Connection Setup.
  • On the WAN configuration page in the section DYNAMIC IP (DHCP) INTERNET CONNECTION TYPE enter the OpenDNS server addresses and for Primary DNS Address and Secondary DNS Address.
  • If there is a check box for Enable Advanced DNS Service, leave it unchecked.
  • Save the configuration changes. Reboot the router is needed.
  • Either reboot your MacBook or simply turn your Airport off and then back on. (This is to refresh your DHCP info so your MacBook will use the OpenDNS DNS servers.)

Response to question update:

DIR-301 is correct and i just double-checked this to be sure, it seems to be an older router you can't find at D-Link anymore because it is out-dated. The Firmware version is 1.02 and i will try to see wether i can update this later on.

OK, I think I found it. The info I found was on the D-Link UK/Europe site. Are you in Europe?

It was listed as part of a DKT-110 Wireless G Starter Kit which contained a DIR-301 router and a DWA-111 USB WLAN adapter. It has apparently been "discontinued". The last firmware released appears to be v1.02 which you have.

I generally do not use any wired connection to the router on any machine.

I would still recommend you try turning off the Airport and using your MacBook via a wired connection for at least long enough to decide if your problem only occurs when using wireless or if it also manifests while using wired ethernet. My feeling is that it always helps to try to narrow done the scope of a problem.

Response to comment:

As i searched the internet for "snow leopard" and "airport" i found pretty much about other people having the same problem, so this is why i assume that it is a general problem snow leopard has in some cases. This is the guide i have used so far: OSX Daily link.

I am certainly in no position to say that there could not be a problem with networking in Snow Leopard. It's just not the first place I would go.

As technologies go, wireless is complicated. I suppose because wireless appears to be "everywhere" these days, people assume it should always just work. When it doesn't then, being human, they look around for a single cause. But there could be lots of reasons a wireless connection could intermittently "fail". That's what it makes it hard to debug in a venue such as this. What is needed is information and it can be frustrating to narrow in on the pertinent pieces of information needed.

Take a look back at items discussed in your link.

  • Changed DHCP auto settings to manual
  • Change Wireless Channels
  • Disabled “Wireless G only” Mode

With the exception of DHCP, none of the above are changes that IMO seem to implicate Snow Leopard. Not having any other information to go on, these changes seem to me to imply either interference problems with the wireless signal or possibly a problem in the router.

Even the problems with DHCP might be a result of signal interference. And that's assuming Mr Mendez had any DHCP problems. He really doesn't say why he disabled DHCP. Perhaps he just read about doing this someplace and figured "What the heck?" Was this actually relevant to his problem in any way? Maybe not. How can we tell?

I'm also frankly not sure why the author thinks disabling “Wireless G only” mode might have been a factor. Is his MacBook now connecting using 802.11b instead of 802.11g? Why should this matter?

I personally don't think it did matter. I think David Mendez just tried changing a bunch of stuff, his connection reliability seemed to him to improve, and he assumed it was a result of the changes he made. Maybe. But also maybe not. There is just no way of telling from the information he provides.

One other comment about his other rag tag list of suggested fixes. Before you go about reseting PRAMs or deleting configuration information there are two other approaches which you can try which are a lot less damaging.

First, you can simply create a new user id on your MacBook and see if you have the problem when using it. If the problem does not occur when using a new userid with the default OS X settings for the hardware then you can suspect something is wrong in the configuration of your main userid. If nothing changes though it implies there is nothing "wrong" in your user settings. All that deleting them would accomplish would be to annoy you.

A second, more tedious approach is to install a clean copy of either Snow Leopard or even Leopard on an external (USB or Firewire attached) hard drive. Again, if the problem goes away when using a fresh OS X install then it implies something is wrong somewhere in your regular copy of OS X. Otherwise the problem is most likely somewhere else in your network.

  • Thx for your detailed answer, it will take some time for me to try this all out. I will definitely come back later and let you know wether this helped me. As i searched the internet for "snow leopard" and "airport" i found pretty much about other people having the same problem, so this is why i assume that it is a general problem snow leopard has in some cases. This is the guide i have used so far: osxdaily.com/2009/09/01/… – Julian Weimer Aug 4 '10 at 10:25
  • Wow! To bad I can give only one upvote! This answer is really great! – AndrejaKo Aug 4 '10 at 18:35
  • +1 for the effort you've put into this one, irrational John – Doug Harris Aug 5 '10 at 17:47
  • Thx again, you are providing very good informations about wireless networks in general and it's good to learn new things too. In the article David Mendez mentioned the same important aspect as you did: wlan problems seem to have many reasons that are possible. But at least you make me feel more motivated about troubleshooting. – Julian Weimer Aug 6 '10 at 15:07

Take a look at AirPort Express, AirPort Extreme and let's not forget Time Capsule! They definitely must work with Mac OS.

Seriously though, you'd better ask questions about your WiFi problems. Any standards compliant router should work flawlessly with any standards compliant operating system.

It'd be best for you to ask a question here and describe what is happening to you with as much details as possible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.