152

Is there a way to stop the gmail address field (on the login page) from displaying all the gmail addresses that you have ever typed in it?

When logging in with Google Chrome or trying to set up a new account, anything you type which starts with the same letter as the one that you are trying to use currently will show up in the auto-complete field, I don't want that.

I understand that this is a convenient feature in some cases, but the thing is--I know this shouldn't've happened, but it has actually happened more than once--I sometimes mistyped my password in the Gmail address field right after the address, mistakingly assuming that the prompt had already been moved to the password field, and then hit "Enter" without looking first. The next time I tried to enter my Gmail address, it popped up the address followed by my password as one of the entries on the list of email addresses that shows up, and I couldn't get rid of the entry.

Is there a way to remove these? The autofill feature in Chrome is a time saver, and so I don't really want to turn it off. It would be helpful to be able to edit out some of the typed info, though, so it won't show up again -- is this possible to do?

  • Your information is not being sent out. It stays on your machine. – Xavierjazz Jan 23 '11 at 11:37
  • 3
    BOOKMARKS!!! For the longest time I was unable to remove an autosuggested field, it turned out it was part of my saved bookmarks. if you cannot shift-delete it, check to see if it's in your bookmarks (does it have a star icon beside it or a magnifying glass). Hopefully that will save someone a lot of trouble that had me scratching my head. :) – eLouai Nov 1 '15 at 19:44
  • You have to now go to passwords.google.com and remove the old logins – Scott Oct 3 '16 at 19:22
179

You can remove entries from the list using the following steps:

  1. Select the "Username" field and make sure it is blank

  2. Press on your keyboard, a list of all of the "remembered" entries should appear.

  3. Using & highlight an entry you would like to delete.

  4. Press delete. (Note that you may need to use shift+delete, fn+delete, ctrl+delete (Ubuntu) in some instances, like if the remembered entry is in the address / URL bar).

  5. Repeat steps 2-4 until satisfied.

To clear login entries for a username/password combination, see another answer.

  • 3
    @AndersonGreen, you can use "Clear browser data..." button on Chrome's Settings page to clear all the entries. Just select Clear saved passwords and Clear saved Autofill form data. – alanaktion Apr 26 '13 at 14:47
  • 41
    It appears as of v28 (possibly sooner), delete alone will not remove entries anymore, you must use shift+delete everywhere now. – Jeff Mercado Jul 18 '13 at 17:55
  • 2
    This doesn't work for me for search entries, just URLs. Does it work for anyone else? Edit: v28 – s4y Jul 20 '13 at 17:59
  • 13
    Had to use fn+shift+delete on Mac OSx Yosemite Chrome. – CenterOrbit Jun 3 '15 at 19:22
  • 6
    To everyone who has reported that this answer doesn't work: if your autocomplete entry is in a login-related field, please see my answer below. – machineghost Sep 16 '15 at 18:54
36

On a Macintosh, type enough text to bring up the autofill entry you would like to remove and use the arrow keys to highlight the entry you would like to delete, then do fn+shift+delete and the entry will be deleted.

  • Cannot get this to work in Mavericks on Chrome 37 – Geuis Oct 17 '14 at 21:44
  • 5
    At first I thought this didn't work. Then I realised it was actually in my bookmarks. If there's a star next to it, you should go to bookmark manager and use the search feature to find it. Mine was labelled "New Tab" – Jason Jan 15 '15 at 22:42
  • After trying many different key combinations, I found out: Ctrl Shift Fn Delete would work. – Bùi Thanh Hải May 13 '15 at 11:21
  • This seems to work but it seems like the deleted entries will stay for the page you are on until you open a new browser tab. – jcollum Jul 31 '15 at 15:37
22

As others have mentioned, the steps in the top-voted answer don't actually work in many cases. This is because Chrome stores autocomplete information for login-related fields separately, and a bug (which is two years old and shows no sign of being fixed) prevents that class of autocomplete info from being cleared with DELETE (or any other combination of keys plus DELETE).

The, unfortunately more awkward, solution is to go to a special Chrome page:

chrome://settings/passwords

That page will show you every username/password combination Chrome has stored (with the passwords blacked out). You can hover over a particular username/password pair to make an "X" appear on the right. If you click on that X it removes the auto-complete entry.

  • 1
    after lots of digging I found this to be worked for me Thanks – Md. Parvez Alam Jul 18 '16 at 5:05
  • Glad I could help. – machineghost Jul 18 '16 at 17:05
  • This didn't work for me. There are no longer passwords in this chrome flag. Rather, I had to go to passwords.google.com and delete the ones that I no longer need. – Scott Oct 3 '16 at 19:21
  • 1
    @Scott Perhaps there is something special about your setup? When I go to chrome://settings/passwords with the latest (v53) Chrome I still see passwords. The dialog does say (at the bottom) "Access your passwords from any device at passwords.google.com", so it seems both places are editing the same list ... but I'm not sure why you aren't seeing them at chrome://settings/passwords like I am. – machineghost Oct 3 '16 at 23:55
6

Update as of August 3, 2015, and if you are a windows user (xp, 7, 8, etc) am still not sure about linux, ubuntu and mac osx?

In order to remove specific history of entries it can be done by pressing shift + delete when you highlighted that specific entry.

Bonus point: You can also do that in Google Chromes urlsearch bar, it means that it is not limited on facebook, gmail, etc email textbox.

(See below image)

enter image description here

Edit:

It is also worth noting that based on raphadco's beneficial comment, shift+delete works only for regular non-password fields, this means that if you saved an account in google chrome then you cannot delete that.

I figured it out.. Shift+Delete won't work if you also have a saved password (login+pass fields), you have to delete in chrome://passwords . Shift+delete works well for regular non-password fields though.

The solution to that problem has been solved by harschware stating that

confirmed. It's crazy but if Chrome is suggesting something in a username field and you don't want that suggested, you must delete the saved password in settings first, and then shift+delete in the field to stop the suggestion from occurring

  • 1
    it works on the search bar, but not on saved fields – raphadko Aug 4 '15 at 21:27
  • @raphadko what do you mean by saved fields? – Cary Bondoc Aug 4 '15 at 23:41
  • 2
    I figured it out.. Shift+Delete won't work if you also have a saved password (login+pass fields), you have to delete in chrome://passwords . Shift+delete works well for regular non-password fields though. – raphadko Aug 6 '15 at 2:31
  • 2
    confirmed. It's crazy but if Chrome is suggesting something in a username field and you don't want that suggested, you must delete the saved password in settings first, and then shift+delete in the field to stop the suggestion from occurring... – harschware Aug 7 '15 at 0:48
1

On Mac you need to cause the autocomplete to be selected and then simultaneously press these three keys on the keyboard.

enter image description here

Sometimes pressing these keys will appear to have zero effect whatsoever (1 in 3 times and more likely when trying to remove reddit.com for some reason). However, closing the tab/window and then reopening it will prove that the autocomplete entry is no longer there.

1

As per suggestion from this comment:

  1. Go to: chrome://settings/autofill

    Alternatively go to Settings (Advanced), then Autofill settings (under Passwords and forms).

  2. Select Manage Autofill settings.

  3. In the dialog, select the entry which you'd like to remove.

See: How to clear unwanted autofill entries in Google Chrome.

0

Type in chrome browser: chrome://settings/clearBrowserData

It will bring up this screen. Got Advance tab and delete only the autofill data or other catagories as well as you desire.

enter image description here

protected by Community Jul 7 '12 at 6:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.