The whole installation goes smoothly up to the point of "Completing installation ...". The monitor changes resolution, after which a standard dialog box pops up saying

Windows Setup could not configure Windows to run on this computer's hardware

Then, in a few seconds, the whole machine powers down. Trying to restart produces the message:

STOP: c000021a {Fatal System Error}

0x00000000 (0xc0000001 0x00100448)

OR it boots into Setup and comes up with the message:

Windows Setup encountered an unexpected error...

(This is not the actual error, just paraphrasing)

I tried using the OEM restore instead of a regular install, but it fails with the same error.
(Even though it worked before...)

General specs:

HP Pavilion Elite e9262f

Intel Core i5-750 Processor

ATI Radeon HD 4650

Hitachi HDT721010SLA360 ATA Device


SuperMulti DVD Burner with LightScribe

Some built-in Wi-Fi module


I've tried disconnecting the wireless card and disabling the built-in Ethernet and Firewire via the BIOS, and replacing the wireless keyboard and mouse with wired USB ones. Didn't work.

I've also tried changing the SATA controller settings in the BIOS to RAID, AHCI, and IDE, reinstalling each time I changed. Still not working.

I think the reason why it is showing the Fatal System Error is because it didn't finish installing before it errored out and shut down, so the system is left in an inconsistent state.

I've tried 3 different copies (including the OEM restore) of Windows 7 now, and they're all failing at the same point, with the same error message. I've tried to install Windows 7 maybe 10 times already, with the exact same error message at the exact same location.

Hm... Interestingly, the 32-bit version of Windows 7 works, but the 64-bit version doesn't.
Perhaps it was a badly burned disk? Reburning the 64-bit version still comes up with the same error.

Here's a picture of the side of the case that clearly says it came with Windows 7 64-bit, along with the model number and CPU.

picture of side of case

sudo fdisk -l:

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009896f

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391    7  HPFS/NTFS
/dev/sda2              14       94119   755906445    7  HPFS/NTFS
/dev/sda3          119922      121602    13492224    7  HPFS/NTFS
/dev/sda4           94120      119922   207257740+   5  Extended
/dev/sda5          119527      119922     3170769   82  Linux swap / Solaris
/dev/sda6          107174      119526    99225441   83  Linux
/dev/sda7           94120      107173   104856192    7  HPFS/NTFS

Partition table entries are not in disk order
  • 3
    You might have to upgrade to Linux ;-) – Cerin Aug 17 '10 at 21:05
  • @Chris S: Ha. I actually have Ubuntu 10.04 (Lucid Lynx) installed, though I was too lazy to boot into the live CD and restore GRUB after installing Windows 7 successfully. – Hello71 Aug 17 '10 at 21:22

Consider resetting the BIOS to its defaults. Also, make sure the configuration in the BIOS is set to use AHCI.

  • I tried RAID, AHCI, and IDE. Reinstalling every time I switched. Switching from IDE to AHCI without reinstalling understandably produces a different BSoD. – Hello71 Aug 3 '10 at 0:12
  • You can get rid of that BSoD if you want to go IDE->AHCI on an existing installation. regedit -> HKLM\SYSTEM\CurrentControlSet\services\msahci, change the key "Start" from 3 to 0. Go into BIOS, enable AHCI, boot into Windows, it'll install the AHCI driver. (I believe this works under Vista but I have only tried 7, it's much harder on XP.) – Shinrai Aug 4 '10 at 22:46
  • Resetting BIOS to defaults and then setting it to use AHCI seemed to work for me! Thanks! – Ryan Oct 21 '14 at 18:46

I'm trying to attack the "stop: c000021a" error.

From thread stop: c000021a {Fatal System Error} :

The fix for this issue, is where the Cable Select Jumper is used (left on by factory), on the Hard Drive and where the BIOS does not support the feature.

Remove the jumper for Cable Select, and depending on the HDD manufacture you may want to try Drive 0 (master) jumper setting.

This fixed a Windows 7 Installation after using Windows 7 install environment to delete all partitions of the existing XP installation, and create a new, and quick formatting NTFS.. The installation hung at 99%, and caused all kinds of Fatal Errors and Blue Screens trying to get it to boot.

Removing the Cable Select Jumper on the HDD immediately fixed the problem.

You can also try out the ideas in this Microsoft article (if they apply) :
How to troubleshoot a "STOP 0xC000021A" error

  • I think Cable Select is a feature of PATA. SATA is pretty much one port, one device, so there is no Master/Slave drives, only the port number. Therefore there would be no Cable Select (If there are master/slave/CS jumpers on the drive, I assume it would only pay attention to those in IDE Emulation mode, and running in AHCI would just ignore that jumper. But I didn't think of jumpers. Hello71 should check the jumpers on the drives. If there are multiple drives, try removing all but the one you're installing on, then reinstall the other drives after installation. – TuxRug Aug 10 '10 at 21:12
  • @TuxRug: There's only one hard drive and one CD/DVD drive. @harrymc: It might take a while, considering that this case seems designed to prevent inserting/removing drives. – Hello71 Aug 11 '10 at 15:35
  • @Hello71: A good heavy hammer will solve ALL problems :) – harrymc Aug 11 '10 at 15:39
  • @harrymc: Being serious, the hard drive 'box' of sorts is literally impossible to remove. Without removing it, it's impossible to remove the drives, as they are vertically positioned within the case, with the CD/DVD enclosure right above it. – Hello71 Aug 11 '10 at 16:09
  • @harrymc: Though, when I did take a look at it, the spot where a jumper would normally be placed was not covered by a jumper (any of the pins). – Hello71 Aug 12 '10 at 0:04
  1. Check for a bios update at HP

  2. Disconnect any hardware you don't need during the install process, if you have on board video, remove any add in video card, disconnect extra hard drives or optical drives, card readers, usb devices (besides keyboard and mouse, use wired ones if you have wireless ones) ect, see if W7 will complete install now.

  • Should I use a PS/2 keyboard and mouse instead of USB? – Hello71 Aug 3 '10 at 1:48
  • If you have some, I have never seen usb kbrd and mouse cause problems like yours. – Moab Aug 3 '10 at 14:26
  • 2
    HP only offers BIOS updates for Windows, which is a problem since... I have a problem installing Windows. – Hello71 Aug 3 '10 at 16:21
  • @Hello71: But you say 32-bit does install, so use it to update the BIOS (be careful not to brick the machine). In any case, most BIOS comes with boot CD (or boot diskette that can be converted to CD). – harrymc Aug 10 '10 at 18:32
  • @harrymc: There's only 1 BIOS update, which I installed before reformatting. – Hello71 Aug 10 '10 at 19:54

Probably a silly suggestion you have already tried, but... are you formatting the partition or installing on top sort of? You say

I think the reason why it is showing the Fatal System Error is because it didn't finish installing before it errored out and shut down, so the system is left in an inconsistent state

If you format your partition it shouldn't be any state at all. If you have several hard drives I would disconnect those.

Other suggestions I agree with is upgrading the BIOS if possible, resetting it and of course making sure that you in fact have a 64-bit CPU.

  • I reformatted using the Windows 7 installer every time. What I mean by that is that Setup started initializing the installation before it errored out and shut down, so the system is left in a half-configured state. – Hello71 Aug 12 '10 at 15:48
  • I'm 110% sure I have a 64-bit CPU. I'll try resetting the BIOS settings sometime, but I doubt it will make a difference. – Hello71 Aug 12 '10 at 15:51
  • @Hello71: Try looking for a BIOS update as well. – Svish Aug 12 '10 at 19:10
  • @harrymc: There's only 1 BIOS update, which I installed before reformatting. – Hello71 2 days ago – Hello71 Aug 12 '10 at 20:44
  • Try using gparted.sourceforge.net/livecd.php to remove all the partitions, then reboot back into the Windows 7 setup. – TuxRug Aug 13 '10 at 22:35

Simply remove USB after the first time it reboots (before complete installation)


According to the following KB, This error occurs because of an issue with the Intel storage controller driver that's included in the released versions of Windows 7 and of Windows Server 2008 R2. This issue is resolved in Windows 7 SP1 and in Windows Server 2008 R2 SP1.



HP Z400, same issue. win8 and windows 10 would both install if I did not format the drive first, but installing windows 7 64 would fail at the "Windows Setup could not configure Windows to run on this computer's hardware"

What fixed it for me was essentially bypassing that error, dropping to command line and completing the out of box experience: TomsHardware Forum

At "windows setup cannot configure windows for this hardware"
Shift F10
Type -
Cd c:\windows\system32\oobe

Fixed mine on my XW6600. I had changed the SATA mode from SATA I to SATA II whereas apparently my WD Green drive is SATA I. Once I flicked it back to SATA I installation resumed perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.