0

I just recently downloaded Notepad++, and I am unable to get the CSVQuery plugin working for it.

  • When I click on the Plugins button, and then click on Plugins Admin..., I cannot find CSVQuery anywhere on the list.
  • When I download the zip file from the github, and follow the directions to install manually (listed HERE), Notepad++ doesn't show anything implying that it is aware of the plugin. It's as if the plugin is not even recognized by Notepad++.

I am currently on Notepad++ v8.3.3.

2 Answers 2

1

This only affects the 64-bit version of Notepad++, however, there is now a new version of CsvQuery that works (1.2.9).
The plugin list in Notepad++ hasn't been updated yet though, that usually takes a while.

2
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 28, 2022 at 9:58
  • This solution works! I had to follow the directions for manual installation, since the proper version isn't on the list (as you mentioned). Here is the link for those looking for it -- npp-user-manual.org/docs/plugins/#install-plugin-manually Apr 29, 2022 at 4:22
2

If you go to your Notepad++ installation location, then go to plugins/Config/nppPluginList.dll, you can see the list of plugins that Notepad++ is aware of and recognizes without any action from you. If you use ctrl+f and look up CsvQuery, you will see the following information.


        {
            "folder-name": "CsvQuery",
            "display-name": "CsvQuery",
            "version": "1.2.8",
            "npp-compatible-versions": "[,8.2.1]",
            "id": "8ed39f3795fcffef09bbfa09b4ed36c6abe1f4200268ed98a7d3f07cb33f81cd",
            "repository": "https://github.com/jokedst/CsvQuery/releases/download/v1.2.8/CsvQuery-v1.2.8-x64.zip",
            "description": "Enables SQL queries against CSV files.",
            "author": "jokedst",
            "homepage": "https://github.com/jokedst/CsvQuery"
        },

The important part is the key named npp-compatible-versions. Notice how the value for that key is [,8.2.1]. This syntax is referring to a range of compatible versions - with the minimum being on the left of the comma, and the maximum being on the right of the comma. As we can see, there is no number to the left of the comma, implying that there is no minimum version, so even the oldest version of Notepad++ should be able to run this plugin. However, to the right of the comma is the version 8.2.1, which implies that the maximum version that this plugin is compatible with is 8.2.1. Therefore, Notepad++ 8.3.3 will not work with this plugin, and that is why Notepad++ refuses to acknowledge it.

Therefore, the solution is to download a compatible version of Notepad++ that can handle this plugin. Since the plugin hasn't been changed in months (according to the GitHub repository), it looks like it doesn't work with more recent versions of Notepad++.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .