1

I know many they have been many discussions about the "system using high CPU" already and I have been trying to solve this problem on my Dell XPS 15 9510 with an NVIDIA RTX 3050Ti ( relevant for later) using many solutions from users and I have concluded using Windows Performance Analyser that the process using all that power was "Nvlddmkm.sys", so I tried reinstalling the driver but it doesn't work.

Then I tried messing with the NVIDIA Control Panel and found out the weirdest thing:

When I'm at idle, no apps running, system is using 8-20% of CPU usage killing my battery life But when I simply open the NVIDIA control panel and Select the "Adjust image setting with preview" page, system goes down on the task manager to about 0.1% of CPU usage and my battery life is back to normal ! It doesn't work on any other page of the NVIDIA Control Panel.

I'm running windows 11, with an Intel i7 11800H 2.30GHz , NVIDIA RTX3050Ti graphics card, 16gb of ram.

Do you have any idea why that is how i could fix this issue (without having to open the NVIDIA control panel all the time) ?

Here are the results of the WPA

With the symbols

7
  • Can you share the etl file capturing the issue? I assume when you had the issue, you ran: wpr.exe -start GeneralProfile left it 15 seconds and ran wpr.exe -stop C:\gp.etl. That should be enough. Commented Apr 9, 2022 at 14:33
  • Thanks, I just added a screenshot of the WPA. Commented Apr 10, 2022 at 16:43
  • See superuser.com/questions/527401/… Does an older version of the driver have the same problem? If not, rollback.
    – Gantendo
    Commented Apr 10, 2022 at 20:21
  • Can you share the etl, there are no symbols and you'd need to expand the stacks more. Commented Apr 10, 2022 at 20:30
  • @Gantendo I dont think this is a driver related problem cause I had the issue before and reinstalling windows solve it but unfortunately it came back after a few months… Commented Apr 11, 2022 at 17:39

1 Answer 1

2

This EXACT same issue occured on my Laptop 2 days ago, even with the CPU usage going down when being tabbed into the NVIDIA control panel, and the Nvlddmkm.sys being the main problem.

After a lot of simply trying things, just disabling the ingame overlay in the GeForce Experience settings solved it for me.

The CPU usage from "System" is now Back to >1%.

1
  • Thank you, it worked for me too ! Commented Apr 30, 2022 at 11:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .