I have googled this 10 hours without finding any useful working solutions. I just fresh installed Windows 11. During the installation, it forces me to use Microsoft account and Windows Hello Pin. And some services also require Hello Pin. Thus I can not disable it.

Now, when I try to use remote desktop, there is a problem. I can not connect. I have no ideas what causes the connection failure. I even not sure what my username is. Is Pin the password? I don't have any password actually. Even microsoft acount web login is using one time password sent to my email. Do I need to provide domain infomartion?

I tried username [email protected], PCNAME\mylon, mylon, Administrator because mylong is my user folder.

I have no ideas what the password is, so I used my Windows Hello Pin.

So far, I have made RDP work by simply disabling Windows Hello Pin.

I have no ideas why Microsoft invents something which does NOT work at all. Especially, Hello Pin is forced to be enabled during installation process and shows as recommended sign-in option in the settings.

8 Answers 8


On a fresh install of Windows 11, password use is disabled.

You can easily enable passwords and that will likely help you on the machine you are trying to RDP into because you will be able to use your password.

Then you can use your Microsoft Account.

See the screen shot with the appropriate settings.

Uncheck the security setting shown.

Enable Passwords

Logout and login with password (not PIN) at least once before RDP access.

Once you login with a password once, you can re-enable the Hello sign-in if you want and still use the password with RDP.

The fix is logging in once with the password.

  • Thanks for your reply. I did the same step to disable Windows Hello Pin. Can we use Windows Hello Pin and Password at the same time? Thanks.
    – sgon00
    Commented Apr 11, 2022 at 2:41
  • 1
    When you change the setting above, you can use PIN or Password (but one or the other at any point in time).
    – John
    Commented Apr 11, 2022 at 10:34
  • Thanks for the reply. That is exactly what I did in my question description. Nothing really new. For me, I want to have both password and PIN at the same time, because some of windows services require PIN to work. Cheers.
    – sgon00
    Commented Apr 11, 2022 at 10:51
  • 1
    The last sentence made me try logging in with my password after enabling RDP and that was apparently the issue. Commented Jun 13, 2023 at 12:44
  • 1
    As per @stringsn88keys comment, it was logout and login with password on my local machine that got RDP working. While I had both PIN and Password enabled on my local machine I had only ever previously used the PIN. Using the Password once to log in allowed me to authenticate to RDP.
    – Simon Elms
    Commented Sep 7, 2023 at 6:45

You can try my case - the computer is connected with MS account and enable MFA. , no need to Uncheck the security setting, keep the PIN and also the MFA. So there are some steps and tricks. Let’s say:

  • namle-zenbook: the remote computer
  • namle-az: the Local Account username on the remote computer
  • le***@li**.com: the Microsoft Account username on the remote computer
  1. Enable Remote Desktop on the Computer that you want to remote.
  2. On that remote computer, press Windows+R to open 'Run' and use the Runas command by entering runas /u:MicrosoftAccount\[email protected] cmd.exe
  3. A Command Prompt will be shown, type your current Microsoft Account password and enter.

Now, you can connect to that computer via Remote Desktop.

We can use both Local Account user (ex: namle-az) and Microsoft Account username (ex: le***@li**.com), with password is the current Microsoft Account password.

enter image description here

You can find the detail here https://nready.net/remote-desktop-on-windows-11-with-microsoft-account-mfa/

  • 5
    I wish this were the selected answer. It's much better than needing to turn off Hello. However, I had to go to the article to get the suggestion to work. The runas command shown in this answer is truncated. It should be: runas /u:MicrosoftAccount\[email protected] cmd.exe
    – dprothero
    Commented May 3, 2023 at 15:27
  • 2
    Can you explain what happened here? Your method worked and I upvoted already. But want to know the sorcery underneath.
    – rafee
    Commented Oct 26, 2023 at 8:37

Just login with your microsoft account password at least once on the target pc!

Credit where credit is due:



  • 4
    This is the correct answer. Disable the Windows Hello sign-in. Login with your password. Enable the Windows Hello sign -in. You can now RDP using a password while having pin enabled.
    – Dejulia489
    Commented Dec 18, 2022 at 15:13
  • +1 I couldn't get anything to work until trying this!
    – ingh.am
    Commented Nov 26, 2023 at 17:40
  • Actually, this does the same as the answer suggested by @Nam-Le. Both work.
    – Miro J.
    Commented Jan 26 at 17:36

I had this same problem. Nothing worked. I resolved this by disabling my PIN (I also had all the other smart unlocks disabled). And then I was able to remote in. I then re-enabled my PIN and everything still worked.

The username used was my email address and password.

  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Aug 24, 2022 at 10:46

Windows 11 - same issue; no local password as Windows was defaulting to a Microsoft account email login, hence no credentials to log in remotely.

Here are the steps I used to resolve this:

Get user id:

  1. Win + R --> Type "cmd" [enter] --> Type "whoami" [enter]
  2. This should show you your userid

Get password:

  1. Click on Windows Icon
  2. Click on User -> Change Account Settings
  3. In Account settings, choose "Sign in with local account" (instead of a Microsoft account)
  4. This should prompt you to create a local password instead of using Windows Hellol, Pin, or whatever

You now have your local userid and password!

A bit frustrating that Microsoft seem to only give you the option of an either/or for local account or microsoft account!


Your Microsoft account has a password. It is what you set when you created it. If you go to https://account.microsoft.com and you enter your emailaddress as username, you then use a password to login to your microsoft account. This webpage also has options to reset it in case you forgot your account.

Once you know your password there, you can use mylon with that password to use RDP.


You have to disable the 'passwordless' login on your MS account online. Log in online, go to security, security dashboard, advanced security options, then turn off 'passwordless account' It will ask you to create a new password. Set this.

Lock your device (that you want to access via RDP), and select forgot PIN. It will ask for your password and MFA. Then ask to set a new PIN, and click cancel. Now your Device has cached your password, RDP will work!!!

  • Maybe it works, but it is highly undesirable. I am perfectly fine and secure without a password in my MSA and have been for years. This situation where I need a password in my MSA didn't exist before Windows 11 23H2 and Remote Desktop worked with a password that was strictly local to the Windows installation. I consider that situation strongly preferred to requiring a password in my MSA. This appears to be a typical situation of throwing away the baby with the bathwater imho.
    – Eric
    Commented Apr 23 at 19:00

In RDP, there's an option to use a web account. It will prompt with the Microsoft Account login UI. This worked for me:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .