I'm stuck after trying and triple-checking everything from the most upvoted answer (from @ntninja) to this question. I did this on two machines - Manjaro and an old Ubuntu 18.04 LTS.

  1. Installed the xdg-desktop-portal-kde.
  2. Edited /usr/share/xdg-desktop-portal/portals/kde.portal to add the value of $XDG_CURRENT_DESKTOP: UseIn=KDE;XFCE.
  3. Added GTK_USE_PORTAL=1 to ~/.pam_environment.
  4. Logged out and back in to apply these changes.

I always get the GTK file dialogs, in every app (Firefox, Thunderbird, gedit, newest VScode), etc). It doesn't work under XFCE nor under KDE/plasma. (I'm aware of the differences regarding the xdg desktop portals).

The "widget.use-xdg-desktop-portal.file-picker"=1 from Firefox's about:config doesn't work either...

Can anybody direct me on how to troubleshoot this?

  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer.
    – Community Bot
    Commented Apr 12, 2022 at 14:25
  • Have you tried setting export GTK_USE_PORTAL=1 in ~/.profile instead of in ~/.pam_environment? Commented Jul 19, 2022 at 19:46
  • I did - to no avail. Same result. Is there some way to get to know, what goes wrong?
    – theciivl
    Commented Aug 26, 2022 at 13:48
  • After a lot of googling a found a partial solution: After killing 'xdg-desktop-portal-gtk' and 'xdg-desktop-portal' and running /usr/lib/xdg-desktop-portal-kde -p BGRx in the terminal, KDE file dialogs are shown under Plasma, but mysteriously not under XFCE. ref. https://www.mail-archive.com/[email protected]/msg584480.html
    – theciivl
    Commented Aug 28, 2022 at 11:54

1 Answer 1


At least on Fedora 36 KDE Plasma to get Plasma/KDE native file dialog In Thunderbird you have to:

  • Open settings ->
  • scroll to the bottom ->
  • click on Config Editor ->
  • search for: widget.use-xdg-desktop-portal.file-picker
  • Set the value to "1" (no quotes) from the default "2".

No need to prefix the program execution with any, above mentioned, environment variables.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .