28

I have always had the same issue with all of my Windows 10 computers - it is essentially impossible to put the computer to sleep with the mouse. When I click Start > Power > Sleep, the computer goes to sleep instantly. Then the act of lifting my hand from the mouse moves the mouse enough to immediately wake the computer from sleep.

Usually, I'm able to fix this issue by disabling "Allow this device to wake the computer" in Device Manager (until the device manager decides that I'm using a new mouse due to system updates or using a different USB port).

However, on my Asus laptop, it seems impossible to actually stop the mouse from waking the laptop:

  • I have disabled "Allow this device to wake the computer" for all devices that have this option in the Device Manager
  • powercfg lastwake shows "Wake History Count - 0"
  • powercfg -devicequery wake_armed shows "NONE"
  • There are no options related to power management/wake-from-sleep in the ASUS UEFI

I can put the computer to sleep via the keyboard or by folding the lid as a workaround, but inevitably at some point the mouse will randomly decide that it's moved at least 1/600th of an inch and the computer will wake up. The only real solution I've found is to unplug the mouse before putting the computer to sleep, which is rather inconvenient.

Are there any additional steps that I can take to prevent the mouse from ever waking the computer? I am looking for a solution that does not require any third-party software.

4
  • 2
    I turn off my mouse first. That works.
    – John
    Apr 15, 2022 at 21:49
  • 7
    @John It's a wired mouse, I can't turn it off without unplugging it.
    – user45623
    Apr 16, 2022 at 2:18
  • If you disable ALL devices from waking your computer, then how do you wake it?
    – Gerry
    Jun 16, 2023 at 17:30
  • @Gerry With the power button
    – user45623
    Jun 17, 2023 at 18:03

7 Answers 7

10

try this

ou mentioned wireless devices in your bag. The laptop with the lid down can wake from sleep. After the time expires from no activity, the laptop goes to sleep. The length is determined by the power settings in the power control panel. This explains the battery drain, since the fan runs full speed to cool the CPU.

You could run cmd.exe as administrator to get around permission errors. But, this does not always work. A better solution is running psexec which makes you localservice. This does not have permission issues removing devices that wake from sleep.

Here is the link https://technet.microsoft.com/en-us/sysinternals/bb896649.aspx or http://download.sysinternals.com/files/PSTools.zip to psexec, part of the Microsoft sysinternals.

Use

psexec -i -d -s cmd.exe to gain access to localservice. From there run:

powercfg.exe /DEVICEQUERY wake_armed It shows a list of devices that can wake the laptop from sleep. I did this on all my laptops. Each one had different devices that could wake it from sleep. Now, to be safe, I removed all of them so that nothing could wake it up. Remove as many as you like.

Run this command to remove a device:

powercfg.exe /DEVICEDISABLEWAKE "your device string goes here" Like

powercfg.exe /DEVICEDISABLEWAKE "HID-compliant mouse (001)" I ran this for each one and verified by running

powercfg.exe /DEVICEQUERY wake_armed again. This time I received None.

I have not had any of my laptops wake up since.

3
  • 7
    The first paragraph of your answer seems to be related to a different question because it has nothing to do with my question. The rest of your answer indicates you didn't fully read my question.
    – user45623
    Sep 9, 2022 at 17:13
  • 2
    Oh, I see, you literally just pasted your answer to another question verbatim. That is not the correct way to use Stack Exchange. In the future, consider linking to the other question instead.
    – user45623
    Apr 21, 2023 at 23:58
  • In addition, to see all "wake-able" devices, type powercfg.exe /DEVICEQUERY wake_programmable, and then, to re-enable a device again (ie. to allow it to awake the PC), use: powercfg.exe /DEVICEENABLEWAKE "Your device string"
    – Fusseldieb
    Jan 29 at 18:33
7

OK, I signed up for an account because this was driving me crazy, too. This didn't solve my problem, but it at least answered the question, and may help solve it for someone else.

I came across this very well written post on Windows 11 Forum that explains the issue:

Your computer is behaving correctly. There is no "fix" for what you are experiencing because there is no fault. You do not have "sleep" despite MS muddying the waters by leaving that as the name of the action in Start, Power & using the word elsewhere. There is no need to run any diagnostic test of any kind. There is no fix of any kind. You have S0 Modern standby aka S0 Low power idle. It is an idle condition. It is not "sleep".

Basically, the traditional "sleep" state (aka "S3", "Standby", or "Suspend to RAM"), where everything was shut off, but RAM kept power so the machine could quickly be woken up has been replaced by a new mode also called "Sleep" (aka "S0 Sleep" or "Modern Standby") where basically the computer stays on and just allows fewer programs to run. This is a result of Microsoft's desire to have computers come to life instantly like people are used to powering on smart phones.

Unfortunately it seems like the Device Manager settings for allowing a device to wake only apply to the older "S3" Sleep, and coming to life with mouse movement is just part and parcel of the new "Modern standby", unfortunately. :(

It seems like (unfortunately for me) on the newest generation of systems there is no support for S3 sleep, but it seems like on some of the systems just a couple years older there is a way to force S3 sleep instead of S0 sleep. You can Google around for how to disable "Modern standby" on your particular computer/O.S. combo. Good luck!

2
  • My mini PC has Standby (S3) enabled but still cannot stop the mouse from waking it up from sleep. So annoying.
    – m4heshd
    Dec 6, 2023 at 23:33
  • 2
    That's such a step backward by Microsoft. Imagine you're on a laptop, go to Standby, only to return to find your battery empty because this fake S0 standby drains battery like crazy..
    – Sigmatics
    Dec 27, 2023 at 17:08
5

Just disable the HID device for it in device manager. No, I don't mean the mouse in device manager. It probably considers it a a keyboard. I made a video about it. Here you go. https://youtu.be/r7RGvhBKO5Y

4
  • 5
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review Dec 13, 2022 at 7:32
  • Thanks! This was true for my Logitech mouse connected via Unifying USB receiver. The receiver can support a keyboard+mouse combo so it even kind of makes sense that it shows up as a keyboard.
    – mik01aj
    Mar 18, 2023 at 21:26
  • This, plus disable all HID-compliant mouse's allow wake up worked for me, thanks !
    – ITFan
    Aug 10, 2023 at 2:58
  • you made my day man. I have tried everything but this is the only solution that worked. Windows thought that my mouse is actually a keyboard :( . thanks again Apr 20 at 5:32
2

Yeah, there is a bug in Windows and I don't know why they can't fix this! Even if you "unarm" the mouse to wake up the PC, it will still wake the PC from any mouse movement. Same goes if you disable the mouse from waking in the device manager. If you untick all devices related to mouse, somehow the signal from mouse will still be received by Windows in sleep state.

The only way I found is to disable all devices related to keyboard. Somehow mouse is paired to keyboard, so when you disable keyboard from waking, the mouse also doesn't wake. But then, you cannot anymore wake up the PC by yourself. Since the bug isn't fixed, not even in Windows 11, your only option is to

  1. live with a waking PC
  2. Buy a new good mouse that isn't shaking the sensor
  3. Disable the keyboard from waking, which will disable the mouse as well automatically.
  4. There is also untested option where some people claim to be able to use a script that disables the mouse device or mouse bluetooth hub before the pc goes to sleep and re-enables the devices when the pc wakes up.
0

The tip I needed was:

A mouse can show up as both a mouse and a keyboard in Device Manager.


These are all steps that I needed:

Open Device manager window, open up the tree for Keyboards and for Mice and other pointing devices, then unplug and reconnect the mouse, and see which devices (dis)appear.

For me, I had HID-compliant mouse and HID Keyboard Device (dis)appearing at the same time.

(I had a few with that same name, so I had to figure out which one of them was the new one. I noticed the Location value in the General tab of its properties were different, so I could detect which were still there when disconnected, and which are new.)

Then for both (for me: HID-compliant mouse and HID Keyboard Device); open its properties, go to tab Power Management (not all devices have that tab), then uncheck Allow this device to wake the computer and hit Ok.

To check, after that, I put laptop to sleep, and neither moving or clicking mouse powered laptop on again
(so it seems you can immediately check, restart was not needed).


Also, before that, running in shell prompt: powercfg -devicequery wake_armed showed both of them, and after unchecking them, they both disappeared, so you can use that too to check which devices you need to disable.

0

I was having the same issue and I solved it by doing the following:

  1. Open Device Manager
  2. Unplug all USB devices except your mouse
  3. Click View In Device Manager | Devices by container
  4. Locate your device (Mine was called USB Receiver)
  5. Expand your specific device tree
  6. Right Click each device and open the Properties
  7. Disable Allow this device to wake the computer
    Note: Some devices in the tree may not have the option. That's okay. Image of device manager showing the only USB Receiver device tree. Each option device underneath this tree has the "Allow this device to wake the computer setting" turned off.
0

Another solution if the above doesn't work...

I too had the same problem but Logitech support helped me fix the problem of waking the PC after 4 minutes. It worked on 2 desktop HP PC's one of which has modern S0 mode (unknown what the other has).

Solution: · Disable USB Selective Suspend:

· Click Start > Control Panel > Hardware and Sound > Power Options > Change Plan Settings > Change Advanced Power Settings > USB Settings > USB Selective Suspend Setting. Change both settings to Disabled.

Go to "Edit Power Plan" to make the changes. On my machine, the USB options was hidden. If you don't see the option, Google how to make the option visible. I only had one setting, so I think their reference to "both settings" might be for wireless mouse and wireless keyboard (ie both).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .