3

i am trying to build an instnace by using an OVA import from my Cloud Storage.

By executing the command :

gcloud compute instances import myinstance --project myProject --byol --source-uri=gs://myBucket/myova.ova

I do get the Error :

ERROR: (gcloud.compute.instances.import)
FAILED_PRECONDITION: generic::failed_precondition: no
concurrent builds quota available to create builds.

By checking the Quotas i can't find anything related to that. Which one should be increades and how ? Can someone explain me what does cause this ERROR ? And how i fix it ?

I have checked the Limit "Concurrent Build Limit" in my Quotas. It is set to 10. That's the maximum.

My Account has enabled billing and i get charged every month.

I would appreciate your help an thank you in Advance. Kind Regards,

A.T

2
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Apr 17 at 9:25
  • What more Details do you need ?
    – A. T.
    Apr 17 at 9:30

2 Answers 2

5

I'll preface this by saying I'm a complete GCP noob. I have been struggling with this issue for the last couple of weeks and just managed to fix it. In my case, I had a CloudBuild trigger set up to listen to pushes to the master branch in my repo, but the build was created under a specific region. Everytime a build was triggered, I would get the same error.

What I did to fix it was: I created a new build trigger, but left the region as "global". If your billing account is set up properly, it may also be a case of adjusting the region setting. Good luck

2
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 24 at 7:25
  • This worked for me as well, I think this is related to Google Cloud Build not working for some regions
    – cjohansson
    Jul 24 at 8:40
4

I can confirm what HovrCat posted. I tried the same and for some reason when creating a new trigger with the region set to "global" it works

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    May 6 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.