My WD raptor 150 failed with a nice clicking noise. So, I picked up a velociraptor 300 and popped it in. I had windows set to do a full system backup nightly, so I figured the recovery ought to go easily.

Well, it isn't. It is currently stuck on a screen that says:

"Windows is restoring your computer from the system image. This might take from a few minutes to a few hours"

Below that is a rather large progress meter with maybe the first block filled in. Below that is a message that says "Restoring disk (C:)..."

It's been that way for over an hour.

The first time around, I gave up after 2 hours. I then booted into the system recovery options and went to a command prompt and ran a chkdsk on the new drive. It showed several file inconsistencies and not much else. I ran a chkdsk /f on it and tried again... Which is where I'm at now.

I can't see that the restore process should take this long before. Any ideas?


After 10 hours, it's still on "Restoring disk (C:)" and the progress meter is at roughly 5%. I'm guessing at the 5% as there isn't an actual number or anything else that I can look at showing what it's actually doing.

The backup contains roughly 120GB of data. How slow is windows restore?


Windows 7 Backup and Restore utility is really slow. I have a system image on a fast eSATA drive and it takes four days to restore it to an internal SATA drive(!) You might be able to speed up the process by switching your SATA controller to IDE mode (instead of AHCI) from system BIOS.

| improve this answer | |
  • ultimately, I ended up just formatting the drive, installing windows and all my applications. Then I accessed the previous backup image to copy my data off. This took about 3 hours; an order of magnitude faster than trying to do a windows restore. – NotMe Nov 29 '11 at 14:28

"This might take from a few minutes to a few hours"

A few hours is longer than two... :) It can take 3+ hours to restore 100+ GB images. Start the restore and leave it overnight. If it's made no advancement by morning then there's something wrong.

| improve this answer | |
  • I guess I'm a little impatient :). I figured after an hour or so the little completion marker should have moved, at least one tick.. I'll let it run overnight this time – NotMe Aug 4 '10 at 4:58
  • See update. After 9 hours it's at roughly 5%. This can't be right. – NotMe Aug 4 '10 at 14:35
  • Doesn't seem right, but if it's advancing, it's doing something. Are you sure the 'new' drive is OK? Have you tried running the WD Diagnostics against the drive to ensure it's OK? What kind of media/interface is the backup image stored on? Have the backup media and the interface (ie: USB or whatever you're using) been tested to ensure they're OK? – Ƭᴇcʜιᴇ007 Aug 4 '10 at 20:06

I had the same issue with a slow restore process. I tried senarvi's suggestion, but I couldn't boot my restore CD when I switched off AHCI mode, thus falling back to IDE mode.

I was stuck with several days of restore in AHCI mode, and no restore in IDE mode.

So I did some Googling, and came across this suggestion:

The suggestion stated by other members didnt work with my Dell XPS 9300 as it doesnt support IDE. However, out of desperation, I switched SATA mode to RAID.

The result? It worked! I didnt have to wait for days to restore a few gigabytes. The re-image process took 20 minutes only to complete.

This also did the trick for me.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.