I setup ubuntu linux subsystem on my windows 11 machine, and configured SSH on it, to allow other devices on my network to connect to it.

It works when I am trying to connect from the same computer:

enter image description here

However, when I connect from another machine or using my private IP from same computer, I keep getting permission denied error:

enter image description here

My hosts.allow and hosts.deny are empty. My sshd_config is:

AllowUsers *

PasswordAuthentication yes

ChallengeResponseAuthentication no

UsePAM yes

X11Forwarding yes

PrintMotd no

AcceptEnv LANG LC_*
Subsystem   sftp    /usr/lib/openssh/sftp-server

How can I enable external connections to my SSH server?



You must log in to answer this question.

Browse other questions tagged .