1

For reasons I cannot explain, the menus in Edge have gone transparent, rendering them nearly impossible to see unless I'm on a website with a dark background. Here is an example:

Tranparent menu that is difficult to read.

This is the Collections menu. Favorites does this as well as any pop-up dialogs that may appear (e.g., an "alert" dialog).

I have reset all settings to default, cleared cache, etc.

Has anyone seen this before? What can I do to fix this?

(I really don't want to reset my user profile. Other accounts don't have this problem. Also, this sycned to other computers where I use this profile.)

FWIW, I had already tried the edge://flags trick and I'm still seeing the transparency.

Screenshot of Edge flags showing Transparency is disabled.

One last bit of information. This is a VM inside VMware Workstation. However, the other place I use the account/profile (syncing is enabled) also exhibited the problem.

Host information regarding DirectX:

Host DirectX general information

Host video general information

Guest information regarding DirectX:

Guest DirectX general information

Guest video general information

1 Answer 1

3

After some more digging, I found this forum post:

https://techcommunity.microsoft.com/t5/discussions/edge-transparent-menus/m-p/3198790

I followed the advice further down regarding the "ANGLE graphics backend" and setting it differently. I set it to "D3D11on12" and it now properly renders the backgrounds:

Edge flag for ANGLE graphics backend set to D3D11on12

Further research on this problem landed me in the VMware Community Forums:

Between the two threads, there does not seem to be a definitive root cause, as there are a mix of recommendations about hardware and 3D settings both at the OS (drivers), VM (vmx settings), and Edge settings. A handful of other applications seem to have a similar glitch as well.

Setting the ANGLE graphics backend to "D3D11on12" seemed to be the most successful workaround.

5
  • D3D11on12 suggests your using hardware that doesn’t necessarily support DX12
    – Ramhound
    Apr 27, 2022 at 2:18
  • 1
    I added some more context to my problem above and to this answer. I did not realize this would have been such an important, but this Windows 10 environment is being run inside VMware Workstation.
    – Corey S.
    Apr 27, 2022 at 11:53
  • So that is exactly the reason you were unable to use the DX12 render and were forced to use DX11 instead. VMWare Workstation does not support DX12 only DX11 ( I want to say it's specifically DX11.1 but don't quote me on that).
    – Ramhound
    Apr 27, 2022 at 11:56
  • 1
    Something stll feels off about that assessment @Ramhound. If I set it to straight D3D11 , it doesn't work. Perhaps the other missing link: the host is Windows 11.
    – Corey S.
    Apr 27, 2022 at 12:04
  • It depends on what feature level D3D11 actually uses. I will do some research
    – Ramhound
    Apr 27, 2022 at 12:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .