In Ubuntu 10.04 all I had to do was turn on my external hard drive and it would automatically be detected and mounted. I just switched over to Ultimate Edition, which I think is Ubuntu 10.04 with a lot of stuff added on to it. The funny thing is when I turn on the external hard drive it doesn't get mounted, and I don't think it's even being detected. I looked in gparted and it doesn't show up there. If I boot into Ubuntu 10.04 and turn on the hard drive it still gets detected and mounted, so there's nothing wrong with it. Ultimate Edition can detect other things connected to USB, like my iPod, so I'm wondering why it can't detect my hard drive.

Edit: When I do tail -f /var/log/messages and if the drive gets detected, this is what it says:

[  230.520892] usb 1-2.4: new high speed USB device using ehci_hcd and address 6
[  230.639400] usb 1-2.4: configuration #1 chosen from 1 choice
[  230.639717] scsi9 : SCSI emulation for USB Mass Storage devices
[  235.631550] scsi 9:0:0:0: Direct-Access     Maxtor   OneTouch         0122 PQ: 0 ANSI: 4
[  235.632631] sd 9:0:0:0: Attached scsi generic sg3 type 0
[  235.633120] sd 9:0:0:0: [sdc] 1465149168 512-byte logical blocks: (750 GB/698 GiB)
[  235.634625] sd 9:0:0:0: [sdc] Write Protect is off
[  235.636443]  sdc: sdc1
[  235.651885] sd 9:0:0:0: [sdc] Attached SCSI disk

When the drive is not detected then it doesn't say anything.


Run tail -f /var/log/messages while you connect the driver. That may give you an idea what is going on. Maybe the usb-storage driver is missing or some driver can't be loaded or there is a bug.

  • I could see how that's helpful. I tried doing that, but this time the drive was detected. – tony_sid Aug 4 '10 at 16:53
  • Keep the program running in a shell and plug your drive in until it doesn't work :-) – Aaron Digulla Aug 5 '10 at 13:16
  • It stopped working again and I tried powering it on while running the program but there's no new information. – tony_sid Aug 7 '10 at 4:46
  • I edited my answer to show what it says when the drive is detected. – tony_sid Aug 7 '10 at 4:54
  • If it doesn't say anything, then you have either found a bug in the USB driver or the hardware is defective. The only workaround I can offer is to keep the file open and plug the drive in repeatedly until it is recognized. Maybe try a different cable and a different port and check that the power supply is OK. If the drive needs too much power, the USB chip might disable it to protect you against damage. – Aaron Digulla Aug 11 '10 at 9:21

I'm running 10.04 and have learned NOT to UNMOUNT the portable hard drive as doing so prevents it from being recognized unless you reboot the computer.

However, if the portable or external USB hard drive is in NTSF format, unless you do unmount it, it cannot be read by a Doze computer. So it's still best to unmount it as you should if you use it on other machines.

After a cold reboot, Plug In your USB Hard Drive and it should be recognized. If you unmount it and turn it off or remove it, plugging it back in and turning it on will not let it be remounted for you. Using a different port will sometimes work, but not always.

This is another bug and/or inconvenience added to version 10.04.... 8.04 was still the best yet, many great user features not present in 10.04....


  • 2
    It is very wrong to say you should NOT Unmount your drive. The point of having an unmount command is so you can unmount your drives. Also, it is wrong to say that once unmounted, your drive will not be recognized till a reboot. Simply run mount /dev/sdXX on your block device to re-mount it and access it. – darnir Nov 6 '12 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.