0

I am trying to make myself a samba server in the cloud but for some reason I cannot access it from my home network. If i vnc into the server on a xfce session I can access the files on the share but can't from my home network. The server has all ports opened in the firewall and I know that works because I have a lot of applications on it including my home's dns server and they work fine. Is it possible to make the share to work from my home network and if yes how would I go about doing that?

2
  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer.
    – Community Bot
    May 7 at 19:47
  • SMB isn't a safe protocol for use in untrusted zones (and neither is VNC), so unless you are using a site2site VPN, this is a bad idea. Since you are using linux, there are already secure tools for doing these kinds of things, including SSH and SFTP. May 7 at 22:52

1 Answer 1

0

Apparently my ISP was blocking smb ports so I added

smb ports = 444 133

to my smb.conf after [global] (I don't know if this is Mac OS specific) but I connected as smb://myip:133/myshare instead of port 444 and after authenticated it works now.

3
  • 1
    This is a bad idea. SMB is not a great protocol and likely to be compromised. A better solution is to more-or-less completely block off everything except management and vpn from the cloud server and use a vpn to connect to it.
    – davidgo
    May 7 at 19:38
  • I already know this but I would like to access the drive easily from my desktop and not have to use something like a sftp program and smb is compatible with more stuff than vpns and I already run a vpn on the server but its hard to like connect and disconnect when accessing my files on the server. I tried nextcloud but I can't seam to find the webserver port open after install so I scraped that idea and just used smb since I can have it mounted as a network drive on windows and make it automout on startup on Mac form system preferences
    – Vlad
    May 18 at 16:05
  • The idea is to set up a vpn and tjen use smb across the vpn You dont need to set up a default route on the vpn so it works while traffic not for server takes its normal path.
    – davidgo
    May 18 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.