21

Since the last update (Firefox 100), the scrollbar in Firefox fades out slowly when you don't move the mouse for a second and immediately reappears when the mouse moves one pixel. This drives me nuts as something moves on the side of text inputs or the page whenever I am trying to read something. I looked for it but found only old posts like this support article and this superuser question that don't seem relevant.

How can this behavior be disabled? Surely there's a preference for something as annoying as this?

3 Answers 3

23
  1. Go to about:preferences or open the Firefox preferences via the UI
  2. Scroll down until you get to a section titled "Browsing", or search for "scroll"
  3. Check the setting "Always show scrollbars"

Update: bonus answer for Thunderbird which met the same fate:

  1. Menu
  2. Settings
  3. Search "Always show scrollbars" and check it
6
  • 7
    For Windows 11 users, Firefox respects the Windows setting. Open settings app and search for "always show scroll bars" to change it.
    – aschmied
    Dec 7, 2022 at 17:58
  • What exactly is the config property name? In Firefox 108, I can't find anything like "Always show scrollbars", and there is no section called "browsing", only "browser".
    – Pointy
    Jan 18, 2023 at 18:03
  • 1
    @Pointy using 108.0.2: snipboard.io/45Aep9.jpg the name and section are exactly as described. Might you have a translation such as British English? In about:config, I think the setting is called widget.gtk.overlay-scrollbars.enabled (set to false to disable tiny scrollbars).
    – Luc
    Jan 19, 2023 at 8:34
  • @Luc my apologies, I read "about:preferences" as "about:config", because I'd been digging around there. Thank you for the clarification.
    – Pointy
    Jan 19, 2023 at 11:58
  • 1
    That said, my own preferences page (Firefox 108, MacOS) does not have such a selection. Maybe it's a MacOS thing. Thank you again nevertheless. edit yes it's a MacOS platform setting in the "Appearances" section (Ventura).
    – Pointy
    Jan 19, 2023 at 12:01
5

I'm adding this because it might help somebody. I'm on Firefox 108 (currently) on MacOS 13.1 "Ventura" (currently). Nothing I tried was working to "stabilize" the scroll bars. I finally stumbled across something MacOS-specific, and that seems to have been the issue for me. On Ventura, the setting is in System Settings -> Appearance -> Show scroll bars.

I'm not 100% sure but I think that might have changed to hide them with the 12->13 upgrade.

3

The precise option in about:config that configures this behavior is (at least on Windows 11):

layout.testing.overlay-scrollbars.always-visible

Set it to true to always have the scrollbar visible.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .