1

There's a HP laptop that was downgraded to Windows 7 from Windows 10. I decided to do that because Windows 10 didn't work properly on such obsolete hardware. The system is much more responding after the downgrade.

However, a persistent problem emerged on Windows 7 that wasn't the case on Windows 10.

Whenever I try to connect to wireless network I get the following error:

enter image description here

On the very first boot (right after the downgrade) I installed networking drivers from the original HP website (choose Windows 7, 64bit), now driver manager looks like this:

enter image description here

Nevertheless, when I shut down the computer and unplug it from the socket on every start I'm faced with "No connections are available". In order to resolve the issue I have to do the following:

  1. Re-install the networking driver (from the original website)
  2. Reboot the computer (without unplugging it from the socket)
  3. Press F12 in order to turn the "wirelessness" on

And I have to do that on every start after I unplug it just to connect to the Internet. There's a severe hardware issue with the battery (I guess the computer can't operate without being plugged in) but there was no such problem when the computer was on Windows 10.

If I reboot OR shut down and start the computer with the computer being plugged in, there's no such networking issue.

What I also noticed is that Bluetooth hardware goes missing after I unplug and start the computer (this is the list of devices when wifi doesn't work).

enter image description here

What can I do to retain the networking drivers (?) after the computer unplugged?

5
  • 1
    Just a guess - try updating the machine's firmware
    – Jonathan
    May 11 at 11:04
  • try downloading the manageability driver back from the HP drivers page if it's available. This will be a large pack that contains all the drivers for that model. Once extracted, manually install all those other base system devices that currently have no drivers and then return to troubleshooting your wireless problem. Those "other devices" that still need drivers might have something to do with the way the motherboard is managing the wifi chip in your computer. Also, make sure you manually get that Win7 OS all the way up-to-date. This could also be related to your wifi problem.
    – Mastaxx
    May 11 at 12:20
  • On a 13-year old Acer, I run Ubuntu and it works well (well, as fast as the old machine can go). It once had Windows, but older versions of Windows are no longer supported, and get no security updates. You might try the same. Many Windows programs have Linux versions (e.g., LibreOffice, Firefox and Ubuntu), and many other Windows programs run perfecly under wine in Ubuntu (e.g., IrfanView, 7-Zip and Sumatra PDF). May 11 at 14:29
  • @Jonathan I've updated BIOS firmware but the issue persists...
    – Joe D
    May 15 at 8:43
  • @Mastaxx I reckon that the issue has to do with incorrect shutdown. If I reboot or shutdown/start the computer without unplugging the cord as many times as I like, it works fine (the drivers are still in place). The issue is only a thing when I unplug the cord. I believe that the computer doesn't shutdown correctly, it's like as if it's still on and then sudden unplug happens and it turns off unexpectedly.
    – Joe D
    May 15 at 9:25

1 Answer 1

1

Firstly, CREATE A RESTORE POINT:

• Click Start ( ), right-click Computer, and then select Properties.

• On the left side of the System window, click System protection.

• Select a disk to store the restore point system files from the list, usually (C:), and then click Create.

Process of Elimination begins now:


Change Power Plan #1 Solution on Internet

Go to start, open Control Panel then open Power Options; now you have to click onChange plan settings right in front of "Balanced (recommended)" - below " Plans shown on the battery meter - after that click on Change advanced power settings now all you need is to find (Wireless Adapter Settings => Power Saving Mode => On battery) and change On battery to Maximum Performance.


Try these four (4) fixes, listed here: https://www.drivereasy.com/knowledge/laptop-keeps-disconnecting-from-wifi-fixed/#d

• Restart your computer and network devices

• Disable your network adapter power saving setting

• Update your network driver (stated below)

• Change Scan Valid Interval


OR SOLUTION 3 https://fixkb.com/2011/04/wireless-problems-without-charger.html

(Read the comments section (scroll down), Many say Solution 1 worked - Change Power Plan- described above)

• Click the Start Button.

• Type “Device Manager” and press Enter.

• Click Continue if prompted.

• Click the [+] next to Network adapters.

• Right Click on “Realtek RTL8191SE Wireless LAN 802.11n PCI-E NIC” or similar Wireless card.

• Click Properties.

• Click on the Advanced Tab.

• Click on 802.11d.

• On the right hand side change the drop down to Enabled.

• The following steps are optional but may help:

• Select TX power level.

• On the right hand side change the drop down to 100%.

• Select Wireless mode.

• On the right hand side change the drop down menu to “IEEE 802.11b/g”.

• If you regularly stream music to other computer in your house do not change these options. Although 802.11b/g are more stable protocols, the maximum speed is 54Mbps.

• Click OK.


With your laptop plugged in, with Internet access, I would download these free driver updaters and carefull select the driver updates/installs which apply to your OS:

Driver Hub: https://www.drvhub.net/

Device Doctor: http://devicedoctor.com/device-doctor-download.php Device Doctor Features

• Provides drivers for every major computer hardware and device manufacturer

• More than 3 terabytes (3,000 GB) of drivers currently in the database

• We cache all drivers so downloads are quick and work every time

• Fast hardware scan takes mere seconds

Driver Easy: https://www.drivereasy.com/download-free-version/

• I find that several of these usually covers drivers that others might overlook

Uninstall these apps after updating drivers!


Lastly... get a new battery if yours is old and cannot hold a charge

Final thought: I have read somewhere that having bluetooth and wifi going at the same time will cause an IP address conflict. Disable bluetooth if you do not need it.

All the best to you and yours

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.