In Thunderbird's message list, we can configure which columns we would like to see. One of these columns is called "Attachments". If we configure the message list to show this column, a paperclip symbol is displayed for each message which contains attachments.

For me, this has never worked reliably, which is going to become a real pain now. In most cases (but not always), the paperclip symbol is not shown after I have received a message with an attachment. I have to open the message and close it again to have the paperclip symbol shown.

Even worse, if I move messages which have the paperclip symbol from my inbox to other folders, they may lose the paperclip symbol; that is, the symbol is no more shown in the message list in the other folders. To get it back again, I have to open the message in the other folder again; then the symbol is back.

I would like to know how to get around that. Even in the inbox, I'd like to see whether a message has an attachment before opening it; having to re-open a message in the new folder after having moved it just to get back the paperclip symbol is a no-go.

I am on TB 91.9.0 x64 / Windows 10 x64.

Any ideas?

P.S. This question does not relate to encrypted messages.

Update 1:

Corrupt index files / folders shouldn't be the problem:

  • I have randomly picked some folders and have repaired them (Right-Click -> Properties -> Repair folder). This didn't change anything; the paperclip symbol was still missing for messages with attachments in these folders.

  • In the left pane, I have selected an account and have compacted it (File -> Compact Folders). According to everything I have read so far, this should compact and repair all folders which are listed in that account, because compaction includes repair. This didn't change anything. In folders in this account, messages with attachments were still missing the paperclip symbol.

  • If have deleted all .msf files in the respective Thunderbird profile and have waited until Thunderbird had downloaded all messages again. Again, this didn't improve the situation. In all accounts in all folders, messages with attachments were still missing the paperclip symbol.

Update 2:

I always fully synchronize all messages in all accounts (Tools -> Account Settings -> -> Sychronization & Storage -> Activate "Keep messages in all folders for this account on this computer").

Update 3:

I forgot to mention that all affected accounts are IMAP accounts. I have multiple PCs with multiple TB instances connected to the IMAP server, and the problems exists in each of the TB installations. Opening a message with an attachment on one PC and closing it again leads to the following situation: On that one PC, the paperclip symbol is shown for that message, but on the other PCs, it still is not shown.

I don't know if the same problem exists with POP3 accounts.

Update 4 (2022-06-11)

Motivated by the comments, I have tested TB 68 in this respect (the portable Windows version, configured to not synchronize messages, i.e. to not download them locally). The result:

TB 68 seems to show the paperclip symbol for every message which contains attachments. But there is the opposite problem: It shows the paperclip symbol even for messages which do not contain attachments.

When I then let a folder download locally in TB 68 (e.g. Right-Click -> Properties -> Synchronization -> Download now), the paperclip symbols get adjusted and are correct afterwards. This is a thing I can live with because I normally let TB synchronize all folders. From a technical perspective, I can understand that in many cases TB may have to scan the whole message to decide whether or not it contains attachments.

So TB 68 behaves correctly (except when not having the folder synchronized).

For clarification, synchronizing a folder / downloading the messages in TB 91 does not have any effect. So we can say that TB 68 works correctly while TB 91 doesn't.

To be honest, I don't know whether I'll waste further time and test it with TB 78.

  • 1
    It works for me. Could be that your folder is corrupt. You can right-click the folder, properties to repair it. See if that fixes it. May also be that you set to only download headers, not full message.
    – LPChip
    May 13, 2022 at 21:10
  • Thank you very much for your hints. Unfortunately, I already did everything which could be related to that; please see my updated question (in a few minutes).
    – Binarus
    May 14, 2022 at 7:11
  • 1
    Hmm, weird one this... Is it possible to try this on a different version of thunderbird, maybe a portable install, just to rule out this is not a bug in thunderbird?
    – LPChip
    May 14, 2022 at 13:09
  • Thanks for the suggestion. I'll try as soon as I have time. I have to figure out how to use the portable version before; I have never tried it out. Personally, I don't expect anything from this test because the problem appears on multiple PCs since a long time, but you are right that I should conduct as many tests as possible.
    – Binarus
    May 15, 2022 at 18:53
  • 1
    But did you install an earlier portable version or the latest? If the bug is in the latest version of thunderbird and you use the latest version everywhere, then the bug will appear everywhere. But you can also download earlier versions of portable versions.
    – LPChip
    May 17, 2022 at 11:37

1 Answer 1


I've asked you to use a different version of Thunderbird which confirmed that the issue does not happen the same way as on the newest version.

This means, the problem is a software one and that gives you 2 options.


  • Find a version that does not have this problem and stick with it for now.
  • Contact the developers and let them know about this bug so they can develop a fix for it so the issue gets resolved in the future, so you can then switch to that version instead.


  • Leave it as it is, optionally using a different version that behaves as good as it can be for your taste and hope that the developers fix the bug in the future.
  • OK, thanks, accepted and +1. I will keep using the newest version and accept that there is just one more bug. Using old versions is not an option for me due to the security risks. Reporting bugs in the case of TB usually is a waste of time; I'll just live with the situation for now.
    – Binarus
    Jun 12, 2022 at 7:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .