1

My laptop recently broke down due to some hardware problems related to the motherboard. To restore my working environment, I plugged out the SSD drive where the operating system is installed and connected it to another computer through a USB SSD hard drive adapter.
I first tried booting directly from it, but the boot process stuck. Then I tried adding this external operating system to the windows boot manager(the new computer has its own Windows installed), but it failed again with a blue screen:

Your PC/Device needs to be repaired
The application or operating system couldn't be loaded because a required file is missing or contains errors.
File: \Windows\System32\winload.efi
Error code: 0xc000000e

So I googled this error code for solutions and found this post.
I then tried all solutions in it, including running automatic repairment, enabling legacy boot, disabling ELAM, running system file check, restoring ESP partition from Windows folder, rebuilding BCD and MBR using bootrec, and none of those solutions worked - They all ended up with the same blue screen code.
But the most wired thing is that the system could always boot successfully on my broken laptop when the SSD is plugged in its original slot(though it has a hardware problem, it's intermittent, which means it still works fine sometimes). The reason I emphasized the condition "in its original slot" is that I've also tried attaching it through the USB adapter and booting, and it failed as well.
So, all my attempts lead to a ridiculous conclusion: the system in this SSD drive seems to bind with that specific slot.
So, may anyone explain what the hell is happening? Or provide some more solutions that I haven't tried yet?
Here is some additional information:

  • Model of my broken laptop: Lenovo Legion Y7000 2019
  • Operating System: Windows 10 Professional 21H1
  • It's an M.2 NVMe SSD drive
  • There's no problem with the SSD drive itself, I've performed a health check already.
  • When using bootrec in safe mode, /FixBoot always failed with the message Access denied.
  • BitLocker is disabled

Well, I've just learned that Windows has a feature related to such a scenario: Windows To Go.
So, is this feature enabled by default on a standard Windows system? Or there are some crucial differences between a portable Windows and a standard one, which might be the root cause of the problem I'm facing?
If that's the case, is there any approach that could turn the Windows in my SSD into a Windows To Go Workspace?

8
  • Most of the time the error you saw means "bad disk" If not the disk, then try a recovery USB from the computer manufacturer. You can also try a bootable USB from the Media Creation Link.
    – John
    May 17, 2022 at 13:55
  • @John I do have a recovery USB. But since my new computer has its own system, there's no need to use it. I did all recovery operations on this system. Besides, I'm very sure the SSD itself is fine
    – 0x269
    May 17, 2022 at 13:59
  • I think it it reasonable to suggest that the broken laptop corrupted the drive on its way out and there may be nothing left to recover (even if you are sure the SSD is good).
    – John
    May 17, 2022 at 14:33
  • Does the file \Windows\System32\winload.efi exist on the disk and can be used (test by copying elsewhere)?
    – harrymc
    May 17, 2022 at 14:38
  • @harrymc Yeah, I've also compared it with the one from the system on my new computer, and they are completely the same.
    – 0x269
    May 17, 2022 at 16:03

1 Answer 1

-1

One solution to the boot failure problem is to disconnect the drive from the computer before you turn on the computer and connect the drive after the operating system has loaded. External hard drives are plug-and-play devices, meaning they don't need the user to configure anything for the device to work.

Access the BIOS

The computer's BIOS can toggle some of the problems that prevent a computer from booting with an external hard drive attached. You can access BIOS from Windows by clicking "Settings" on the Charms Bar, selecting "Change PC Settings," clicking "General" and choosing "Advanced Startup Restart Now." Select "Troubleshoot," "Advanced Options," "UEFI Firmware Settings" and "Restart" to reboot into BIOS.

Disable USB Legacy Support

The computer may boot correctly with the external hard drive connected if USB Legacy Support is disabled. USB Legacy Support enables the computer to use USB peripherals without running operating system drivers and can cause the system to hang on boot when an external hard drive is connected. USB Legacy Support can be turned off through the BIOS. BIOS configuration menus vary between computers: look around the menus using the keyboard arrow keys until you find "Legacy USB" support and disable it. Save and exit BIOS to remedy the problem.

Change the Boot Order

The computer may be set to prioritize booting from USB devices over internal hard drives which can cause the system to hang when you turn it on. Computers list the BIOS boot priority options in different locations, but they can usually be found under the "BOOT" tab. Use the arrow keys and on-screen instructions to move the "USB" option below the "Hard Drive" option to fix the issue. Save and exit BIOS and the computer should boot normally with the drive attached.

Remove Problematic Files

The external hard drive may contain some files in the root directory that are confusing the computer on boot. The problematic files can be removed without adverse effects to the device. To view hidden files, select the "Show hidden Files and Folders" option from the "Control Panel," select the "View" tab, click the radio button next to "Show hidden files and folders" and hit "OK." Delete the hidden files found on the external drive's root directory in File Explorer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.