4

To begin with the original problem, I am locked out of my Dell laptop. It happened following my previous question.

What happened is, I updated the BIOS via the Dell update utility. After reboot, Dell logo did not appear and pressing F12 did not allow me access to BIOS. The accepted answer to my question allowed me to access BIOS through Windows 10. After that, I disabled secure boot in bios and enabled legacy boot.

I thought that if the PC did not detect external DVD or USB, it will simply boot Windows 10 from the hard drive. I was mistaken. It did not and now I have no access to the BIOS to undo the changes I made — that is, re-enable secure boot and disable legacy boot.

I have a second HP laptop that has an internal DVD drive and the Arch Linux (2020) live distro burned onto a DVD. I booted it and I was presented with a list of options; the last one allows reboot into firmware setup which I tested and it worked. Not only that, later I booted the Linux OS and executed the command:

systemctl reboot --firmware-setup

That also worked; remember: This is all on the unaffected HP laptop.

Since my Dell laptop doesn’t have internal DVD drive, I thought that burning the Arch Linux to USB will allow me to do the same: Reboot into firmware setup.

After burning the ISO to the USB and booting it on the Dell laptop, the OS booted differently than it did using the DVD on HP. There was no option to reboot into firmware setup from the presented list.

I thought it wasn’t a big deal. All I had to do is load the OS and execute the previous command:

systemctl reboot --firmware-setup

After executing the command, I got an error message--I don't really remember what it was, but what matters is that it failed...

My Dell PC is now useless. I lost access to the OS and I don't know what to do.

What do you suggest I do?

2

4 Answers 4

3

"Reboot into firmware" uses UEFI runtime features, which are inaccessible when the system has been booted in legacy mode. (Specifically, it sets the 'OsIndications' EFI variable.)

Official Arch .iso images support both legacy and UEFI boot; if you wrote the exact image to USB (e.g. using dd) your laptop's boot menu should offer two choices for the same USB stick. Make sure you select the UEFI one.

(The two modes may use different bootloaders, e.g. you might see a themed Syslinux menu when booting in legacy mode but a more barebones "systemd-boot" menu while in UEFI mode.)

However, if you use tools which insist on adding their own bootloader, they might ask you to select between legacy vs UEFI modes before writing to the USB disk. If that's the case (e.g. in Rufus), make sure you select GPT/UEFI.

This might actually be advantageous if you can't get to the boot menu at all – in that case, use Rufus to create an UEFI-only USB stick to avoid the system automatically choosing the wrong mode. Alternatively, if you're using 'dd' or similar, you can achieve this by zeroing out the first 440 bytes of the USB device (the BIOS boot sector).

Finally, if the firmware boots so fast that it doesn't give you time to press anything, it usually helps to hold the key before even powering the computer on. That is, hold Esc while pressing the power button.

3
  • Using dd seems the easy way since it is what I used to burn the iso to the usb. How do I zero out the first 440 bytes?
    – machine_1
    May 20 at 11:11
  • head -c 440 /dev/zero > /dev/sdz, or if you prefer, dd if=/dev/zero bs=440 count=1 of=/dev/sdz. Afterwards, either it'll boot in UEFI mode or won't boot at all (depending on what you actually did in the firmware), but either way it won't end up choosing the wrong mode.
    – user1686
    May 20 at 11:12
  • it didn't work :(
    – machine_1
    May 20 at 11:25
1

I am writing this answer from my recovered Dell laptop.

On my Hp laptop that has Windows 10 installed, I downloaded Hiren’s BootCD and burned it on USB using Rufus. In Rufus, under Partition Scheme, I chose MBR and under target system BIOS (or UEFI-CSM).

After Rufus completed, I inserted the USB in my Dell laptop and booted the OS. I then downloaded the earliest bios update from Dell’s website that is specific to my machine.

After download was complete, I ran the program and installation started. The BIOS was successfully flashed and after the system rebooted, the Dell logo appeared and I was able to access the BIOS by (pressing F12) and re-enable secure boot and disable legacy boot.

After reboot, Windows 10 was loaded and I logged in successfully.

1

Everything that happened was pretty normal.

Windows was installed in a UEFI and Secure Boot environment, if you set it as CSM Mode, Windows will not boot since nothing was done to make them work right out of the bat (provided there's a way to do that) when the swtich happened.

Your drive is very likely to be GPT, but Windows don't want to boot on a BIOS with a GPT drive. This is also why you couldn't boot to Windows.

It's not that Arch boots differently from external DVD drive and USB drive, but it's because you're now on CSM mode.

However, it seems pretty weird that you can't access the UEFI on your Dell Inspiron. If it's not F12, it then may be F2, Esc, F1 or any other key since it looks like there's no password set on the UEFI.

What's your Dell Inspiron's precise model (so we can tell you which key you do need to press) ?

If all do fail, please physically remove your hard drive from the Dell Inspiron, start the PC and wait for some message like "Can't find boot device, press F1 to go to Setup", press the right key then switch back from CSM Mode to UEFI and Secure Boot enabled.

Do note that UEFI and Secure Boot are an ungodly mess even 10 years after it got out.

To make things simpler, do reinstall your Windows in CSM Mode or at the very least, disable Secure Boot and reinstall it.

Update 1: Looks like you're not the only one with that issue after a UEFI update (look for "Inspiron" "7559" "BIOS"), some did solved it by removing disconnecting the battery first, then remove the UEFI battery, wait for a minute then reconnect everything back: https://old.reddit.com/r/Dell/comments/bf326p/dell_inspiron_7559_cant_access_bios_or_boot/

Luckily, it seems your laptop only need a single screw to be removed in order to reach everything : https://www.notebookcheck.net/Dell-Inspiron-15-7559-Notebook-Review.154635.0.html

After that, F2 or F12 should work again.

4
  • Inspiron 15 7000 series, 7559. Please note that before the bios update, I could access the bios by pressing F12
    – machine_1
    May 20 at 16:17
  • @machine_1: Then the only way to know is to physically remove the drive and see which key it'll ask you to press. That is, if you have already tried F2, Esc, F1, etc first.
    – X.LINK
    May 20 at 16:23
  • Looks like you're not the only one with that issue after a UEFI update, some did solved it by removing disconnecting the battery first, then remove the UEFI battery, wait for a minute then reconnect everything back. Luckily, it seems your laptop only need a single screw to be removed in order to reach everything : notebookcheck.net/… After that, F2 or F12 should work again.
    – X.LINK
    May 20 at 16:36
  • I have watched a video on YouTube : youtu.be/QRIZiY89uqc I don't think am capable of carrying out such a complicated disassembly
    – machine_1
    May 22 at 9:00
0

I believe that you have installed a partially incompatible BIOS on your computer. You were not able to enter this BIOS, but Windows was still bootable. You then used my answer to enter this BIOS and changed some parameters that made Windows unbootable.

You are now at an impasse, because boot-device selection does not work in the new BIOS, so you cannot reinstall Windows or force-flash the old BIOS version. Your computer is now bricked, for all intents and purposes.

You should have used Windows, when it was still working, to install the previous version of the BIOS that worked perfectly well.

I don't really see here a solution. It is possible to force the installation of a BIOS version, but this requires some hardware devices that a professional would have.

I suggest to admit defeat and ask for help from a professional repair shop, perhaps even from Dell. They will be able to force-install a correct version of the BIOS (ensure that they don't use the same one as you did). These repairs will cost, but this will be cheaper than a new computer.

Once this is fixed, you shouldn't install a new BIOS as long as the one that is installed works well. The risks are just too large if you are not aware of the possible dangers.

7
  • Can I not use BiosDisk to flash an older bios version using arch linux? I read it works in legacy mode
    – machine_1
    May 22 at 18:54
  • Biosdisk is a FreeDOS based utility, meaning that you have to boot a FreeDOS USB disk. For that you need to change the boot order from the BIOS, which you can't. You are truly blocked.
    – harrymc
    May 22 at 18:57
  • I am capable of booting OSes from usb. I don't understand
    – machine_1
    May 22 at 18:58
  • I think I misunderstood your question. If you can boot USB, you may use Linux to create the BiosDisk boot disk and install the old BIOS. The BiosDisk installation notes are for Linux. I'll fix my answer if that works for you.
    – harrymc
    May 22 at 19:01
  • Yes, can you please provide all the steps to flash the bios using biosdisk?
    – machine_1
    May 22 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.