0

I am following the instructions for a brand new Framework laptop DIY edition. So I have a hard drive with no OS installed at all.

I have put the .iso on the usb drive using the Fedora Writer application. I then ejected the drive from the machine used to create it. I plug it into my brand new DIY Framework and see a message that reads:

Default Boot Device Missing or Boot Failed.

Insert Recovery Media and Hit any key

Then Select 'Boot Manager' to choose a new Boot Device or to Boot Recovery Media

Then the Boot Option Menu shows no options. I am trying to run Fedora 36. I’ve tried re-writing to the usb drive to see if I did it wrong, and got the same results. After I press escape, I get a message that reads “No bootable device — please restart system”

I have also tried removing the 2 other bays to only have the battery and the usb-a slot filled to see if that helped. I get the same results.

I've also tried this with Fredora 35, and got the same results.

I have confirmed that the USB itself is bootable by booting from it on the Windows 10 machine on which it was created.

I am running BIOS InsydeH20 Version GFW30.03.07

I have disabled Secure Boot. Ran all over the options I see in F12... this is disappointing.

1
  • 1)Can you share pictures of your BIOS settings to see if anything else stands out? 2)Maybe try a power discharge (remove battery & power cord then hold power button 10sec), reconnect everything & try again. 3)you mention making the USB drive with the Fedora Writer app, yet latter you mention testing it on the Win10 PC it was created so contradicting...maybe you tried with two PC's? Good thing is is boots with another PC so it seems drive & the boot-setup seems to be fine & sadly isolated to this laptop of yours. 4)try resetting BIOS/UEFI to defaults. 5)have you reached out to the company?
    – gregg
    May 26, 2022 at 2:49

1 Answer 1

0

Did you try pressing F12 during power-on to get boot menu where you select EFI USB device? https://guides.frame.work/Guide/Fedora+36+Installation+on+the+Framework+Laptop/108

https://knowledgebase.frame.work/how-do-i-boot-from-a-usb-drive-H1uzph2Ru

4
  • Thanks for the links. I've tried several things: unplugging and plugging the drive back in while it's in the Boot Manager, Restarting after 35 seconds, confirming that the keyboard works with F2... The F12 thing seems to be a waste of my time as it only ever goes into the Boot Manager. May 25, 2022 at 4:45
  • Try replugging the USB when you're in the Boot Manager.
    – HoD
    May 25, 2022 at 5:35
  • Not sure why F12 is a waste of time, that's how you override the default boot device/order which is the hard drive when it's connected so you need to do it to boot USB. However your edited question seems to imply this screen isn't showing your USB drive which would normally indicate it not formatted/setup correctly, yet you mention it boots on another PC. @HoD is correct the second link says to try unplugging it & plugging it back in WHILE at the F12 boot screen. Also it links to some other tips: knowledgebase.frame.work/en_us/…
    – gregg
    May 26, 2022 at 2:54
  • It also mentions this is a firmware issue so sounds like you need to contact the company if none of these links or comments are helping you
    – gregg
    May 26, 2022 at 2:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .