3

I am using PGAdmin 4, the application, on Ubuntu 20.04.1 (Zorin 16). I am using an SSH tunnel and an identity file. This works. However every time I connect, I am prompted for a password for the identity file. The file is not password protected, other than filemode of 600. There does not seem to be any issue with not supplying the password, but is it supposed to be the password of the remote SSH login, or the password of my current user for "su" purposes? Or is it just a glitch?

Inspecting the properties, the buttons (and these are of a fat pair radio buttons in lieu of a checkbox) are not persistently remembering my choice to use a private key.

3
  • Have the same issue and cannot find a fix Sep 28, 2022 at 6:53
  • This has been killing me for the past day and a half. More annoyingly, this was working last week, can figure out what changed that killed this. The Identity file password field never came up until I tried to opened a session yesterday.
    – discoStew
    Nov 4, 2022 at 14:09
  • I'm also having exactly the same issue. Dose anyone got any answer for it yet?
    – MacUsers
    Nov 11, 2022 at 23:08

2 Answers 2

0

I was getting the same error, just provided my database master password it worked.

1
  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center. Nov 30, 2022 at 4:30
0

It is a red herring. Ignore the request for the password key file. Just click OK to bypass it without entering anything.

Then you just enter your database password as you normally would have.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.