0

I have an Acer Aspire 5552G laptop with a strange power-up problem. When I press the power button, the power light comes on (hard disk activity and wifi lights stay off) and nothing happens after that, even the screen backlight is not initialized. I wait for some time, press and hold the power button to turn it off, and then turn it on again, and the same issue. After multiple attempts, it decides to turn on properly and shows the POST screen, and boots into Windows 10. After I shut it down and turn it on again, the issue repeats. (with a restart from Windows I have not seen the issue happen)

The same issue happens on battery power, with the charger plugged in and also with just the charger without the battery. One of the screws is stripped and I'm unable to open the case to do a BIOS reset but I would like to know if anyone has experience with this kind of issue.

Thanks.

Config : AMD Phenom II N930, 2+1 GB DDR3 SODIMM, 240GB ADATA SSD

Updates/Observations :

  1. Yesterday the laptop didn't turn on correctly even after around 20 attempts. Tried with different RAM sticks but no use. Finally decided to remove the battery and use just with the charger and then it turn on.

  2. I narrowed down the issue to a faulty battery and then tried to shut it down and turn on without the battery. The issue repeated so maybe it's even more than just the battery.

  3. The BIOS version is 2.04 and the latest for this model is 2.14 (although I couldn't find the latest for download from Acer website). I was able to find a 2.13 version from a different website. I will try to update the BIOS and see what happens.

2
  • 1
    There appears to be something wrong in the internal power circuit and connection circuit. I suggest taking the machine to a local computer shop and have it serviced.
    – John
    May 31 at 15:19
  • Sounds like a dodgy capacitor.
    – davidgo
    May 31 at 20:14

2 Answers 2

1

I totally agree with you @Cristian but I don't RAM is creating some problem because it was doing that then laptop won't turn on after number of attempt. And if it loading perfectly after multiple attempts then the RAM must be okay.

Instead, I would suggest you to two solutions which you can try.

  1. Take out the battery of your laptop and then press and hold the power button for 5-8 seconds. And then plugin the battery then try powering it normally.

  2. Check for BIOS settings like, date-time are correctly configured and Boot order is correctly configured. If you are having issue with the date-time in BIOS then change your CMOS battery.

Hope it helps :)

1
  • Suggestion 1 did not change anything Suggestion 2 : Used the default BIOS configuration, Date and time are correct. Nothing changed.
    – Ajay Meda
    Jun 1 at 13:46
0

Well, If I have to diagnose that I would:

  • Check RAM (Try it on a different PC), try a different one or even if have two slots try one and then the other.
  • there was any Bios update recently? If not, look for any bios update to perform.

I would bet my money to RAM. Doesnt sounds like power problem Cause you have already tryed it only battery and only charger and problem persist. If its on the board power management... then you're out of luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.