2

Good morning,

I'm very new to this community and would deeply appreciate patience with this question:

I'm having a lot of problems getting PuTTY to run on my Windows 10 laptop after downloading the program. I'll put my system information below for reference.

My System Information:

OS Name Microsoft Windows 10 Pro System Model HP ProBook 450 G8 Notebook PC System Type x64-based PC Processor 11th Gen Intel(R) Core(TM) i7-1165G7 @ 2.80GHz, 2803 Mhz, 4 Core(s), 8 Logical Processor(s) BIOS Mode: UEFI Driver -- C:\WINDOWS\SYSTEM32\DRIVERS\KDNIC.SYS (6.1.0.0, 32.52 KB (33,296 bytes), 12/7/2019 3:07 AM) Serial Port Info -- serial Serial port driver c:\windows\system32\drivers\serial.sys Kernel Driver No Manual Stopped OK Ignore No No

PUTTY: Current Version of PuTTY: 0.77, released on 2022-05-27

PuTTY Version Link: https://www.chiark.greenend.org.uk/~sgtatham/putty/releases/0.77.html

I downloaded PuTTY 64-bit x86 for my Windows 10. Every time I attempt a download, everything is fine until I try and open PuTTY for use. I'll then get the popup error message below: PuTTY Error Message

I then opened up Troubleshoot, hoping to find the issue there. The results from the Troubleshooting are that PuTTY is an "incompatible" program. Picture below: Troubleshooting: Incompatible Program

Once Troubleshooting had run its course, I also tried to repair the issue. PuTTY still wouldn't open. Troubleshooting Report: Repair Screen

I tried to find the error in the PuTTY FAQ section but found nothing that matched this particular issue.

I've never downloaded this program before, so there aren't any previous versions available to run.

In an attempt to see if the x32 would run, I downloaded it and ran into the same issues. I've also double-checked my system information to ensure I had the correct download: 64-bit x86 is correct for my system.

My firewall isn't blocking PuTTY either.

Just to be sure I'm understood, the command line won't open for a PuTTY session, and nothing is logged in the PuTTY "Loggin" section.

I'm not sure what I'm doing wrong but any ideas would be GREATLY appreciated!

2
  • Do you have by chance downloaded the Putty version 64-bit Arm? Make sure you have downloaded the 64-bit x86 or 32-bit x86 version.
    – Robert
    Commented Jun 3, 2022 at 7:18
  • No I made sure I didn't ,click on the 64-bit ARM. I keep trying the 64-bit x86, but just to make sure, I tried downloading the 32-bit version and had the same results. Commented Jun 7, 2022 at 0:53

1 Answer 1

0

If MS Windows 10 (or more precisely Windows Explorer) reports incompatibility when starting putty.exe, you can try to fix the issue by making a change in the Registry:

Run Regedit and open the following key (Ctrl+L and paste the path):

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Store

Then on the right side of the Regedit window find a value that corresponds to putty.exe and delete it.

The next time you run putty.exe from Windows Start Menu or Windows Explorer (which both work from explorer.exe process), the Registry value will be recreated.

That way I fixed the issue with starting putty 0.79 on MS Windows 10 Pro. 22H2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .