21

I asked Windows 7 to index my entire "Media" folder. After it was done it'd find anything in there, no problem.

Then I reorganized it a bit and moved some folders around, and now it doesn't find things inside those folders anymore. For example, I'm looking at a folder with the files:

01. Ferry Corsten - Shelter Me.mp3
02. Ferry Corsten - Black Velvet.mp3
...   
05. Ferry Corsten - Made Of Love.mp3
...

I type in "Love" in the search box for the current folder, and it doesn't find anything.

I checked in "Indexing Options", and this very folder is checked off in there. It seems I just messed up its indexing feature. Any ideas how fix?

29

Control panel->indexing->advanced->rebuild

I've seen several similar questions and as far as I know there's no way to reindex just one directory. Would be great if someone could prove me wrong though.

  • 1
    Thank you, works great, +1. Quick tip for anyone following, hitting the windows key and typing "index" gives quick access to the Control Panel / Indexing panel. – zx81 Jan 17 '16 at 21:42
  • It's horrible to have to do a whole rebuild. There are two solutions shown below that DO purport to work. I tested today on Win 10. FYI the one by Giacomo Mosca worked, certainly and immediately - for a single folder. The one by Fahad Mahmood did not work. – MicrosoftShouldBeKickedInNuts Feb 6 '20 at 19:43
18

You can re-index a single directory:

Folder properties --> Advanced --> untick index --> apply changes

Go back to Advanced --> tick the index files option again

This will now re-index that particular directory. Hope this helps.

  • This totally answers the question on how to reindex a folder. Works on Windows 10. – kiatng Oct 27 '16 at 3:24
  • That would seem to work, as it makes perfect sense, but I tested it just now on Windows 10 and it did not reindex. FYI the solution below by Giacomo Mosca worked, certainly and immediately - for a single folder. – MicrosoftShouldBeKickedInNuts Feb 6 '20 at 19:44
3

I've found no other working solution for re-indexing just one specific folder than that:

  1. close all open programs, which may access the folder in question
  2. copy your folder. For example if your folder is named to_be_indexed, copy it to a new folder named to_be_indexed - Copy. In Windows Exlplorer you may simply use ctrl-c ctrl-v shortcuts, having selected the folder to be re-indexed
  3. wait for indexing to complete (check Windows "Indexing Options", status is given on top of window)
  4. remove the original folder to_be_indexed. Be careful to check before if your copy in step 1 was successful - you do not want to lose data ... (if you want to play safe, rename to_be_indexed to to_be_indexed_old and delete it later)
  5. rename to_be_indexed - Copy to to_be_indexed
  6. wait for indexing to complete (check Windows "Indexing Options", status is given on top of window)
  7. to_be_indexed is now re-indexed in Windows Search

Cumbersome, but works.

  • Wouldn't you acheive the same by renaming the original to something_bak and then copying to folder to the origianl name? – JonC Sep 3 '15 at 11:38
  • Owwww, file dates (i.e. folder dates) are also torched by this if I'm reading it correctly. FYI, I just tested other answers here, and the one by Giacomo Mosca worked for one dir, on Win 10. I'm not sure about Win 7. – MicrosoftShouldBeKickedInNuts Feb 6 '20 at 19:58
2

Experienced the same issue today and forced a specific folder to be re-indexed, without rebuilding in it's entirety.

  • Control panel-> indexing options-> modify-> select your folder you wish to index by de-selecting it with a check mark, initially for exclusion -> Ok to confirm
  • Close the window
  • Control panel-> indexing options-> modify-> select your folder by selecting it again with a check mark, removing it from exclusion -> Ok to confirm

Index will be re-created as the folder has now come into scope for the indexing system

  • +1; yours is the only correct answer for the question asked, based on my current testing on Win 10. Sorry that your answer appears at the bottom, and with fewest votes :( (Fair disclosure, I did not test on Win 7, in case it gives different results. THIS answer is the way to go for Win 10 though.) – MicrosoftShouldBeKickedInNuts Feb 6 '20 at 19:54
1

Click on the Windows Start button, then:

  • Type 'index' (without the quotes)
  • From the list of available options, select 'Indexing Options'
  • Click on the 'Advanced' button
  • On the 'Index Settings' tab, select the 'Rebuild' button, which is under 'Troubleshooting'
  • Click the 'Ok' button
  • Click the 'Close' button

NOTE:

When you initiate this process, you will not be able to see your drives, folders and sub-folders until they are re-indexed. So, make certain that you're not in a hurry to access any data on your hard drive before starting.

This process will take a while; and it's best to do it when no other applications are running. As far as I know, there is no notification to indicate when it's finished re-indexing your drive. Suffice to say, if you watch a movie, or a ball game, by the time you get back the task should be complete.

  • It's horrible to have to do a whole rebuild. There are two solutions shown below that DO purport to work without requiring a full rebuild. I tested today on Win 10. FYI the one by Giacomo Mosca worked, certainly and immediately - for a single folder. The one by Fahad Mahmood did not work. – MicrosoftShouldBeKickedInNuts Feb 6 '20 at 19:48
0
  • Under Indexing options click "Modify ".
  • Then click the folder that you want to update the indexing.
  • Uncheck and then remark the folder.
  • Click on "OK "
  • The folder will be reindexed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.