0

Consider visiting a website that have a expired SSL certificate. Google Chrome (Version 102.0.5005.115, Windows 10) presents a warning:

NET::ERR_CERT_AUTHORITY_INVALID

However, I trust the sites as another web service builds these for me.

How do you adjust Custom level Internet Options only to remove this security warning?

Internet options: Trusted site is selected. Option Custom Level is highlited. Not my computer

I don't want to "fix" the certificate problem, I want to "whitelist" some websites thru Internet Options. Again, I don't know what store the certificate or the chain. I think that Chrome just browses the "Internet" and Internet Options allow me to edit rules regarding the "internet". my main goal is to make the custom level only let through sites with SSL problems and certificate problems, albeit the title could be changed. Oh, the screenshot was only to highlight the position of the "Custom level..." option, from a blog post some where else.

3
  • 1
    Internet Properties doesn’t effect Google Chrome. Which certificate store did you install this invalid certificate exactly, also understand, Google Chrome has rules regarding certificates which are not easily (sometimes impossible) to bypass. It also looks like you are under the heal of a system Administrator who should make the modifications
    – Ramhound
    Jun 19 at 14:51
  • @Ramhound I don't want to "fix" the certificate problem, I want to "whitelist" some websites thru Internet Options. Again, I don't know what store the certificate or the chain. I think that Chrome just browses the "Internet"and Internet Options allow me to edit rules regarding the "internet". my main goal is to make the custom level only let through sites with SSL problems and certificate problems, albeit the title could be changed. Oh, the screenshot was only to highlight the position of the "Custom level..." option, from a blog post some where else. Jun 19 at 15:38
  • Internet Options doesn’t apply to Chromium or Firefox. When you edit your question to include adequate information I will answer your question
    – Ramhound
    Jun 19 at 16:28

1 Answer 1

1

How do you adjust Custom level Internet Options only to remove this security warning?

You don't. There isn't any setting that would remove this security warning. The only way to avoid it is to import the website's certificate into the browser's "trusted certificates" store.

I think that Chrome just browses the "Internet"and Internet Options allow me to edit rules regarding the "internet".

The "Internet Options" panel isn't really an Internet options panel – it's the options panel for one specific HTTP client (Microsoft WinHTTP), one specific TLS library (Microsoft SChannel), and one specific HTML renderer (Microsoft MSHTML), i.e. it mostly controls components of the Internet Explorer browser.

Almost nothing you do there affects other browsers, most of which bring their own HTTP and TLS libraries (not to mention HTML renderers). For example, Google Chrome uses BoringSSL as the TLS library and doesn't really care about IE settings at all.

Actually, trusted certificates are practically the only exception to this – Chrome does use the certificates provided by SChannel and managed through this control panel. You're looking for Content → Certificates which has a section "Trusted Root Certificate Authorities". Visit the website, export its certificate to a file, then use the control panel to import it into "Trusted Authorities".

Screenshot of Chrome's "Certificate information" popup enter image description here enter image description here enter image description here

(Though it's more common to do that through certmgr.msc rather than "Internet Settings", but both really manage the same list.)

However, I trust the sites as another web service builds these for me.

The warning isn't really about whether you trust the sites, at all. The point here is that the browser doesn't know whether it is connecting to the intended site in the first place, or whether it's being rerouted to somewhere else.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.